summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-devtools/python/python-pygobject_2.27.91.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-devtools/python/python-pygobject_2.27.91.bb')
-rw-r--r--meta/recipes-devtools/python/python-pygobject_2.27.91.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pygobject_2.27.91.bb b/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
new file mode 100644
index 0000000000..49ee1083cf
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pygobject_2.27.91.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Python GObject bindings"
2SECTION = "devel/python"
3LICENSE = "LGPLv2.1"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a916467b91076e631dd8edb7424769c7"
5DEPENDS = "python python-pygobject-native glib-2.0"
6DEPENDS_class-native = "python-native glib-2.0-native"
7RDEPENDS_class-native = ""
8PR = "r6"
9
10MAJ_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
11
12SRC_URI = "${GNOME_MIRROR}/pygobject/${MAJ_VER}/pygobject-${PV}.tar.bz2 \
13 file://obsolete_automake_macros.patch \
14"
15
16SRC_URI[md5sum] = "2b11a3050264721aac83188224b093a8"
17SRC_URI[sha256sum] = "a1dffbe2a8e0d490594554ed8d06f0ee4a371acb6c210e7f35158e9ae77e0df4"
18S = "${WORKDIR}/pygobject-${PV}"
19
20FILESPATH = "${FILE_DIRNAME}/python-pygobject:${FILE_DIRNAME}/files"
21EXTRA_OECONF += "--disable-introspection"
22
23PARALLEL_MAKEINST = ""
24
25inherit autotools distutils-base pkgconfig
26
27# necessary to let the call for python-config succeed
28export BUILD_SYS
29export HOST_SYS
30export STAGING_INCDIR
31export STAGING_LIBDIR
32
33PACKAGES += "${PN}-lib"
34
35RDEPENDS_${PN} += "python-textutils"
36
37FILES_${PN} = "${libdir}/python*"
38FILES_${PN}-lib = "${libdir}/lib*.so.*"
39FILES_${PN}-dev += "${bindir} ${datadir}"
40
41BBCLASSEXTEND = "native"