summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.21.5.bb
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2016-01-19 21:56:27 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-20 17:07:14 +0000
commit7721652a0fe82fc5ae127398a025781a94664a34 (patch)
tree96ce29b2d9ffae6ee4df1f94064358ca19c9f1b7 /meta/recipes-devtools/python/python-pycurl_7.21.5.bb
parent2ef401f96cff60de592a6dee71c55b2f65b98b8a (diff)
downloadpoky-7721652a0fe82fc5ae127398a025781a94664a34.tar.gz
python-pycurl: upgrade to 7.21.5
License checksum changed for file COPYING-MITLicense checksum changed for file README.rst (From OE-Core rev: 9fb7b19916b65cab01bd072e4536c6e2eea202ce) Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.21.5.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.21.5.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.21.5.bb b/meta/recipes-devtools/python/python-pycurl_7.21.5.bb
new file mode 100644
index 0000000000..af517a1fa7
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.21.5.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python bindings for libcurl"
2HOMEPAGE = "http://pycurl.sourceforge.net/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1+ | MIT"
5LIC_FILES_CHKSUM = "file://README.rst;beginline=166;endline=182;md5=a84a1caa65b89d4584b693d3680062fb \
6 file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
7 file://COPYING-MIT;md5=b7e434aeb228ed731c00bcf177e79b19"
8
9DEPENDS = "curl python"
10RDEPENDS_${PN} = "python-core curl"
11SRCNAME = "pycurl"
12
13SRC_URI = "\
14 http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
15 file://no-static-link.patch \
16"
17
18SRC_URI[archive.md5sum] = "bca7bf47320082588db544ced2ba8717"
19SRC_URI[archive.sha256sum] = "8a1e0eb55573388275a1d6c2534ca4cfca5d7fa772b99b505c08fa149b27aed0"
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit distutils
23
24# need to export these variables for python-config to work
25export BUILD_SYS
26export HOST_SYS
27export STAGING_INCDIR
28export STAGING_LIBDIR
29
30BBCLASSEXTEND = "native"
31
32# Ensure the docstrings are generated as make clean will remove them
33do_compile_prepend() {
34 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
35}
36
37do_install_append() {
38 rm -rf ${D}${datadir}/share
39}