summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2015-11-05 17:44:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-11-25 07:50:33 +0000
commitaa07eb161c229eef6b8852203103c18766e2e369 (patch)
treee4c9b07d5a557c989ec814ef8824a5bc3706d07c /meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb
parent696aa7e86b7f38c6a94bb5a934bafd6b3f71d055 (diff)
downloadpoky-aa07eb161c229eef6b8852203103c18766e2e369.tar.gz
python-pycurl: update version to 7.19.5.2
No change in License. Updated no-static-link.patch README.rst: license checksum changed to reflect the Copyright update COPYING-MIT: checksum changed to reflect the Copyright update (From OE-Core rev: 8b990fd7054feaaaccce2819b5a915419c636a4a) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb b/meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb
new file mode 100644
index 0000000000..094105c685
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.5.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Python bindings for libcurl"
2HOMEPAGE = "http://pycurl.sourceforge.net/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1+ | MIT"
5LIC_FILES_CHKSUM = "file://README.rst;beginline=166;endline=182;md5=e5c36c3ca7e9f0bf6e144267dd760861 \
6 file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
7 file://COPYING-MIT;md5=0c3eb58d2e99f3102e2ce2db4eb172f1"
8
9DEPENDS = "curl python"
10RDEPENDS_${PN} = "python-core curl"
11SRCNAME = "pycurl"
12
13SRC_URI = "\
14 http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
15 file://no-static-link.patch \
16"
17
18SRC_URI[archive.md5sum] = "59cea96cc3027a1a7ed5020e69d4009a"
19SRC_URI[archive.sha256sum] = "98cc821555d152977fac99b6e5cb0f759275aabdf14e4928890c6fcc944ab736"
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit distutils
23
24# need to export these variables for python-config to work
25export BUILD_SYS
26export HOST_SYS
27export STAGING_INCDIR
28export STAGING_LIBDIR
29
30BBCLASSEXTEND = "native"
31
32# Ensure the docstrings are generated as make clean will remove them
33do_compile_prepend() {
34 ${STAGING_BINDIR_NATIVE}/${PYTHON_PN}-native/${PYTHON_PN} setup.py docstrings
35}
36
37do_install_append() {
38 rm -rf ${D}${datadir}/share
39}