summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-pycurl_7.19.3.bb
diff options
context:
space:
mode:
authorLaurentiu Palcu <laurentiu.palcu@intel.com>2014-02-06 17:29:32 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-02-09 09:42:53 +0000
commitedbf9ef4a37ddb63f10e8f100fcbd188c19fdff7 (patch)
tree144fa8db646d3bd44d402aa36281c57bd3bf32a5 /meta/recipes-devtools/python/python-pycurl_7.19.3.bb
parent3bfb713d1cffadde17a0fcf85d87ad9769622bda (diff)
downloadpoky-edbf9ef4a37ddb63f10e8f100fcbd188c19fdff7.tar.gz
python-pycurl: upgrade to 7.19.3
Changes: * Refreshed no-static-link.patch; * LGPL&MIT license files changed names; * MIT license file added a contributor to the list; * README.rst license snippet changed to reflect the filename changes and the new contributor; (From OE-Core rev: b5b4898cd409036161c62891e9618d9ab3f891f9) Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-pycurl_7.19.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-pycurl_7.19.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-pycurl_7.19.3.bb b/meta/recipes-devtools/python/python-pycurl_7.19.3.bb
new file mode 100644
index 0000000000..aee6cdda82
--- /dev/null
+++ b/meta/recipes-devtools/python/python-pycurl_7.19.3.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Python bindings for libcurl"
2HOMEPAGE = "http://pycurl.sourceforge.net/"
3SECTION = "devel/python"
4LICENSE = "LGPLv2.1+ | MIT"
5LIC_FILES_CHKSUM = "file://README.rst;beginline=204;endline=219;md5=57e5ab0c0f964533fc59d93dec5695bb \
6 file://COPYING-LGPL;md5=3579a9fd0221d49a237aaa33492f988c \
7 file://COPYING-MIT;md5=e8200955c773b2a0fd6cea36ea5e87be"
8
9DEPENDS = "curl python"
10RDEPENDS_${PN} = "python-core curl"
11SRCNAME = "pycurl"
12
13SRC_URI = "\
14 http://${SRCNAME}.sourceforge.net/download/${SRCNAME}-${PV}.tar.gz;name=archive \
15 file://no-static-link.patch \
16"
17
18SRC_URI[archive.md5sum] = "b9091b7438d3de1552e28862d2971cd1"
19SRC_URI[archive.sha256sum] = "05e48835fe445ff327dcd373f49d9970e0b828a07cd4d08a23264507a742d616"
20S = "${WORKDIR}/${SRCNAME}-${PV}"
21
22inherit distutils
23
24# need to export these variables for python-config to work
25export BUILD_SYS
26export HOST_SYS
27export STAGING_INCDIR
28export STAGING_LIBDIR
29
30BBCLASSEXTEND = "native"
31
32do_install_append() {
33 rm -rf ${D}${datadir}/share
34}