summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-numpy_1.7.0.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2014-01-14 15:19:29 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-01-14 17:03:56 +0000
commit4ec992938a65eb656539c3f5974100b04f752273 (patch)
tree7bd5b84708d0cea2e384e68506451abbe9b9d65d /meta/recipes-devtools/python/python-numpy_1.7.0.bb
parent7282635343e0ccf7a82ffdb35905bdc2db6093d3 (diff)
downloadpoky-4ec992938a65eb656539c3f5974100b04f752273.tar.gz
python-numpy: add (from meta-oe)
python-numpy is needed for Piglit. This recipe is taken directly from meta-oe. (From OE-Core rev: 9bf355cceaec6ebacdcbcc35f9713ff73e1c85da) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-numpy_1.7.0.bb')
-rw-r--r--meta/recipes-devtools/python/python-numpy_1.7.0.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-numpy_1.7.0.bb b/meta/recipes-devtools/python/python-numpy_1.7.0.bb
new file mode 100644
index 0000000000..04cb2f183f
--- /dev/null
+++ b/meta/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -0,0 +1,78 @@
1DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "PSF"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
5PR = "r1"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
8 ${CONFIGFILESURI} "
9
10CONFIGFILESURI ?= ""
11
12CONFIGFILESURI_aarch64 = " \
13 file://config.h \
14 file://_numpyconfig.h \
15"
16CONFIGFILESURI_arm = " \
17 file://config.h \
18 file://numpyconfig.h \
19"
20CONFIGFILESURI_armeb = " \
21 file://config.h \
22 file://numpyconfig.h \
23"
24CONFIGFILESURI_mipsel = " \
25 file://config.h \
26 file://numpyconfig.h \
27"
28CONFIGFILESURI_i586 = " \
29 file://config.h \
30 file://numpyconfig.h \
31"
32CONFIGFILESURI_x86-64 = " \
33 file://config.h \
34 file://_numpyconfig.h \
35"
36
37S = "${WORKDIR}/numpy-${PV}"
38
39inherit distutils
40
41# Make the build fail and replace *config.h with proper one
42# This is a ugly, ugly hack - Koen
43do_compile_prepend_class-target() {
44 BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
45 ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \
46 true
47 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
48}
49
50FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
51
52SRC_URI[md5sum] = "4fa54e40b6a243416f0248123b6ec332"
53SRC_URI[sha256sum] = "f4fa70b7edbab65ee6432eb63743f5489f1919c614632b20b2fb45aa7e682ac6"
54
55# install what is needed for numpy.test()
56RDEPENDS_${PN} = "python-unittest \
57 python-difflib \
58 python-pprint \
59 python-pickle \
60 python-shell \
61 python-nose \
62 python-doctest \
63 python-datetime \
64 python-distutils \
65 python-misc \
66 python-mmap \
67 python-netclient \
68 python-numbers \
69 python-pydoc \
70 python-pkgutil \
71 python-email \
72 python-subprocess \
73 python-compression \
74"
75
76RDEPENDS_${PN}_class-native = ""
77
78BBCLASSEXTEND = "native nativesdk"