diff options
author | Alejandro Hernandez <alejandro.hernandez@linux.intel.com> | 2016-01-19 21:56:30 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-01-20 17:07:15 +0000 |
commit | 918149d340c93227fa2cc97ea2a9013983f487e6 (patch) | |
tree | 6ad9a61625be21abf5d04765ff1e24c706df9bc2 /meta/recipes-devtools/python/python-numpy_1.10.4.bb | |
parent | eae758496e5fab0cb10b72c4539225e669d00e1d (diff) | |
download | poky-918149d340c93227fa2cc97ea2a9013983f487e6.tar.gz |
python-numpy: upgrade to 1.10.4
Updates runtime dependencies, numpy now depends on python-ctypes and python-threading.
(From OE-Core rev: d76756150ef749899906a7df98df8712ab73dc8f)
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-numpy_1.10.4.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-numpy_1.10.4.bb | 100 |
1 files changed, 100 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-numpy_1.10.4.bb b/meta/recipes-devtools/python/python-numpy_1.10.4.bb new file mode 100644 index 0000000000..01bf9fba21 --- /dev/null +++ b/meta/recipes-devtools/python/python-numpy_1.10.4.bb | |||
@@ -0,0 +1,100 @@ | |||
1 | SUMMARY = "A sophisticated Numeric Processing Package for Python" | ||
2 | SECTION = "devel/python" | ||
3 | LICENSE = "PSF" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9f4e88b5748e8313caaf33d081ce65a3" | ||
5 | |||
6 | SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \ | ||
7 | file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \ | ||
8 | ${CONFIGFILESURI} " | ||
9 | |||
10 | CONFIGFILESURI ?= "" | ||
11 | |||
12 | CONFIGFILESURI_aarch64 = " \ | ||
13 | file://config.h \ | ||
14 | file://_numpyconfig.h \ | ||
15 | " | ||
16 | CONFIGFILESURI_arm = " \ | ||
17 | file://config.h \ | ||
18 | file://numpyconfig.h \ | ||
19 | " | ||
20 | CONFIGFILESURI_armeb = " \ | ||
21 | file://config.h \ | ||
22 | file://numpyconfig.h \ | ||
23 | " | ||
24 | CONFIGFILESURI_mipsel = " \ | ||
25 | file://config.h \ | ||
26 | file://numpyconfig.h \ | ||
27 | " | ||
28 | CONFIGFILESURI_x86 = " \ | ||
29 | file://config.h \ | ||
30 | file://numpyconfig.h \ | ||
31 | " | ||
32 | CONFIGFILESURI_x86-64 = " \ | ||
33 | file://config.h \ | ||
34 | file://_numpyconfig.h \ | ||
35 | " | ||
36 | CONFIGFILESURI_mips = " \ | ||
37 | file://config.h \ | ||
38 | file://_numpyconfig.h \ | ||
39 | " | ||
40 | CONFIGFILESURI_powerpc = " \ | ||
41 | file://config.h \ | ||
42 | file://_numpyconfig.h \ | ||
43 | " | ||
44 | CONFIGFILESURI_powerpc64 = " \ | ||
45 | file://config.h \ | ||
46 | file://_numpyconfig.h \ | ||
47 | " | ||
48 | CONFIGFILESURI_mips64 = " \ | ||
49 | file://config.h \ | ||
50 | file://_numpyconfig.h \ | ||
51 | " | ||
52 | CONFIGFILESURI_mips64n32 = " \ | ||
53 | file://config.h \ | ||
54 | file://_numpyconfig.h \ | ||
55 | " | ||
56 | |||
57 | S = "${WORKDIR}/numpy-${PV}" | ||
58 | |||
59 | inherit distutils | ||
60 | |||
61 | # Make the build fail and replace *config.h with proper one | ||
62 | # This is a ugly, ugly hack - Koen | ||
63 | do_compile_prepend_class-target() { | ||
64 | BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \ | ||
65 | ${STAGING_BINDIR_NATIVE}/python-native/python setup.py build ${DISTUTILS_BUILD_ARGS} || \ | ||
66 | true | ||
67 | cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/ | ||
68 | } | ||
69 | |||
70 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a" | ||
71 | |||
72 | SRC_URI[md5sum] = "90bb9034652cefbada19cf7d141a6a61" | ||
73 | SRC_URI[sha256sum] = "f7f91842056a7cf680b0eaf8cefc5e46c69e2521e651128d2e6aaaccec8652ae" | ||
74 | |||
75 | # install what is needed for numpy.test() | ||
76 | RDEPENDS_${PN} = "python-unittest \ | ||
77 | python-difflib \ | ||
78 | python-pprint \ | ||
79 | python-pickle \ | ||
80 | python-shell \ | ||
81 | python-nose \ | ||
82 | python-doctest \ | ||
83 | python-datetime \ | ||
84 | python-distutils \ | ||
85 | python-misc \ | ||
86 | python-mmap \ | ||
87 | python-netclient \ | ||
88 | python-numbers \ | ||
89 | python-pydoc \ | ||
90 | python-pkgutil \ | ||
91 | python-email \ | ||
92 | python-subprocess \ | ||
93 | python-compression \ | ||
94 | python-ctypes \ | ||
95 | python-threading \ | ||
96 | " | ||
97 | |||
98 | RDEPENDS_${PN}_class-native = "" | ||
99 | |||
100 | BBCLASSEXTEND = "native nativesdk" | ||