summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-nose_1.3.7.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2017-11-18 16:19:18 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-13 14:00:52 +0000
commita61146fe9d129f28985ab28db56f7d4af71d34d1 (patch)
treea20b4485af9ab5f663fca511872f005be8282c23 /meta/recipes-devtools/python/python-nose_1.3.7.bb
parent2eed409aa729c4119d000c98bf2d209e0aa8ff3d (diff)
downloadpoky-a61146fe9d129f28985ab28db56f7d4af71d34d1.tar.gz
python-nose: use pypi.bbclass
* Simplify python- and python3-nose by using pypi.bbclass * Consolidate common content in python-nose.inc - Avoid duplication by using PYTHON_PN variable (From OE-Core rev: 351e741cea4538cfe30640bd6e451c0fbc1d0329) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-nose_1.3.7.bb')
-rw-r--r--meta/recipes-devtools/python/python-nose_1.3.7.bb25
1 files changed, 1 insertions, 24 deletions
diff --git a/meta/recipes-devtools/python/python-nose_1.3.7.bb b/meta/recipes-devtools/python/python-nose_1.3.7.bb
index 9b3509cafb..6d69d2d62e 100644
--- a/meta/recipes-devtools/python/python-nose_1.3.7.bb
+++ b/meta/recipes-devtools/python/python-nose_1.3.7.bb
@@ -1,25 +1,2 @@
1SUMMARY = "Extends Python unittest to make testing easier"
2HOMEPAGE = "http://readthedocs.org/docs/nose/"
3DESCRIPTION = "nose extends the test loading and running features of unittest, \
4making it easier to write, find and run tests."
5SECTION = "devel/python"
6LICENSE = "LGPLv2.1"
7LIC_FILES_CHKSUM = "file://lgpl.txt;md5=a6f89e2100d9b6cdffcea4f398e37343"
8
9SRC_URI = "https://files.pythonhosted.org/packages/source/n/nose/nose-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "4d3ad0ff07b61373d2cefc89c5d0b20b"
12SRC_URI[sha256sum] = "f1bffef9cbc82628f6e7d7b40d7e255aefaa1adb6a1b1d26c69a8b79e6208a98"
13
14UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/nose/"
15UPSTREAM_CHECK_REGEX = "/nose/(?P<pver>(\d+[\.\-_]*)+)"
16
17S = "${WORKDIR}/nose-${PV}"
18
19inherit setuptools 1inherit setuptools
20 2require python-nose.inc
21RDEPENDS_${PN} = "\
22 python-unittest \
23 "
24
25BBCLASSEXTEND = "native nativesdk"