diff options
author | Alejandro Hernandez <alejandro.hernandez@linux.intel.com> | 2015-02-11 17:57:49 -0600 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-02-23 17:35:29 +0000 |
commit | cb02ecb507ddad3cb17c78020b42c004aa2903ae (patch) | |
tree | 0f30353b3c8a3aaf6294f8db9c8fb7cff5575ab9 /meta/recipes-devtools/python/python-native_2.7.9.bb | |
parent | 122ee11bd1817f776336e54898cb36162fe527df (diff) | |
download | poky-cb02ecb507ddad3cb17c78020b42c004aa2903ae.tar.gz |
Python: Upgrade from 2.7.3 to 2.7.9:
- Based on Paul Eggletons work to partially upgrade to Python 2.7.6
Modified:
default-versions.inc: switched to python 2.7.9
generate-manifest-2.7.py: fixed _sysconfigdata
python-2.7-manifest.inc: fixed _sysconfigdata
python.inc: Updated checksums and source, no LICENSE
change just updated some dates
python-native_2.7.3 -> python-native_2.7.9 and updated patches
python_2.7.3 -> python_2.7.9, and added ac_cv_file__dev_ptmx=no
ac_cv_file__dev_ptc=no in EXTRA_OECONF to solve python
issue #3754, only needed when cross compiling, also updated patches
use_sysroot_ncurses_instead_of_host.patch: New patch to use ncursesw
from sysroot instead of hosts, introduced by fix for python issue #15268
Rebased:
01-use-proper-tools-for-cross-build.patch
03-fix-tkinter-detection.patch
05-enable-ctypes-cross-build.patch
06-avoid_usr_lib_termcap_path_in_linking.patch
avoid_warning_about_tkinter.patch
builddir.patch
fix_for_using_different_libdir.patch
host_include_contamination.patch
multilib.patch
nohostlibs.patch
search_db_h_in_inc_dirs_and_avoid_warning.patch
Deleted (fixed on upstream):
06-ctypes-libffi-fix-configure.patch
CVE-2013-4073_py27.patch
gcc-4.8-fix-configure-Wformat.patch
json-flaw-fix.patch
posix_close.patch
pypirc-secure.patch
python-2.7.3-CVE-2012-2135.patch
python-2.7.3-CVE-2013-1752-smtplib-fix.patch
python-2.7.3-CVE-2014-1912.patch
python-2.7.3-CVE-2014-7185.patch
python-2.7.3-berkeley-db-5.3.patch
python-fix-build-error-with-Readline-6.3.patch
remove-BOM-insection-code.patch
remove_sqlite_rpath.patch
python2.7.3-nossl3.patch
[YOCTO #7059]
(From OE-Core rev: d4ad95f0d5f08891637c644e85b09da9c4585059)
Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.9.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-native_2.7.9.bb | 61 |
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.9.bb b/meta/recipes-devtools/python/python-native_2.7.9.bb new file mode 100644 index 0000000000..dfde36129f --- /dev/null +++ b/meta/recipes-devtools/python/python-native_2.7.9.bb | |||
@@ -0,0 +1,61 @@ | |||
1 | require python.inc | ||
2 | |||
3 | EXTRANATIVEPATH += "bzip2-native" | ||
4 | DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native" | ||
5 | PR = "${INC_PR}.1" | ||
6 | |||
7 | SRC_URI += "\ | ||
8 | file://05-enable-ctypes-cross-build.patch \ | ||
9 | file://10-distutils-fix-swig-parameter.patch \ | ||
10 | file://11-distutils-never-modify-shebang-line.patch \ | ||
11 | file://12-distutils-prefix-is-inside-staging-area.patch \ | ||
12 | file://debug.patch \ | ||
13 | file://unixccompiler.patch \ | ||
14 | file://nohostlibs.patch \ | ||
15 | file://multilib.patch \ | ||
16 | file://add-md5module-support.patch \ | ||
17 | file://builddir.patch \ | ||
18 | file://parallel-makeinst-create-bindir.patch \ | ||
19 | " | ||
20 | S = "${WORKDIR}/Python-${PV}" | ||
21 | |||
22 | FILESEXTRAPATHS =. "${FILE_DIRNAME}/${PN}:" | ||
23 | |||
24 | inherit native | ||
25 | |||
26 | RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native" | ||
27 | |||
28 | EXTRA_OECONF_append = " --bindir=${bindir}/${PN}" | ||
29 | |||
30 | EXTRA_OEMAKE = '\ | ||
31 | BUILD_SYS="" \ | ||
32 | HOST_SYS="" \ | ||
33 | LIBC="" \ | ||
34 | STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \ | ||
35 | STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \ | ||
36 | ' | ||
37 | |||
38 | do_configure_prepend() { | ||
39 | autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf" | ||
40 | } | ||
41 | |||
42 | do_install() { | ||
43 | oe_runmake 'DESTDIR=${D}' install | ||
44 | install -d ${D}${bindir}/${PN} | ||
45 | install -m 0755 Parser/pgen ${D}${bindir}/${PN} | ||
46 | |||
47 | # Make sure we use /usr/bin/env python | ||
48 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do | ||
49 | sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT | ||
50 | done | ||
51 | |||
52 | # Add a symlink to the native Python so that scripts can just invoke | ||
53 | # "nativepython" and get the right one without needing absolute paths | ||
54 | # (these often end up too long for the #! parser in the kernel as the | ||
55 | # buffer is 128 bytes long). | ||
56 | ln -s python-native/python ${D}${bindir}/nativepython | ||
57 | |||
58 | # We don't want modules in ~/.local being used in preference to those | ||
59 | # installed in the native sysroot, so disable user site support. | ||
60 | sed -i -e 's,^\(ENABLE_USER_SITE = \).*,\1False,' ${D}${libdir}/python${PYTHON_MAJMIN}/site.py | ||
61 | } | ||