diff options
author | Morgan Little <morgan.little@windriver.com> | 2012-07-19 13:46:06 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-07-22 11:42:20 +0100 |
commit | 093ed41b0f0d89cb6344acdf6bb62cb9ca597f2f (patch) | |
tree | 56d957638ae1769a111c9bb178cada565d8c9740 /meta/recipes-devtools/python/python-native_2.7.3.bb | |
parent | 5bdd9988d9e64814191fb7480d6a4c1355b019cc (diff) | |
download | poky-093ed41b0f0d89cb6344acdf6bb62cb9ca597f2f.tar.gz |
python-native: Put binaries in seperate directory
Update python-native to install the binaries in the python-native directory,
add pythonnative.bbclass to let recipes that need python-native use the
binaries and update disutils access the new binaries. Update distutils-base
to inherit pythonnative.
(From OE-Core rev: a2e554f731437545e9483a7a73e6847c03f6f48a)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.3.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-native_2.7.3.bb | 10 |
1 files changed, 6 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.3.bb b/meta/recipes-devtools/python/python-native_2.7.3.bb index 50bf894d0c..bfdcd12687 100644 --- a/meta/recipes-devtools/python/python-native_2.7.3.bb +++ b/meta/recipes-devtools/python/python-native_2.7.3.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require python.inc | 1 | require python.inc |
2 | DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native" | 2 | DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native" |
3 | PR = "${INC_PR}.0" | 3 | PR = "${INC_PR}.1" |
4 | 4 | ||
5 | SRC_URI += "file://04-default-is-optimized.patch \ | 5 | SRC_URI += "file://04-default-is-optimized.patch \ |
6 | file://05-enable-ctypes-cross-build.patch \ | 6 | file://05-enable-ctypes-cross-build.patch \ |
@@ -20,6 +20,8 @@ inherit native | |||
20 | 20 | ||
21 | RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native" | 21 | RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-core-native" |
22 | 22 | ||
23 | EXTRA_OECONF += " --bindir=${bindir}/${PN}" | ||
24 | |||
23 | EXTRA_OEMAKE = '\ | 25 | EXTRA_OEMAKE = '\ |
24 | BUILD_SYS="" \ | 26 | BUILD_SYS="" \ |
25 | HOST_SYS="" \ | 27 | HOST_SYS="" \ |
@@ -34,11 +36,11 @@ do_configure_prepend() { | |||
34 | 36 | ||
35 | do_install() { | 37 | do_install() { |
36 | oe_runmake 'DESTDIR=${D}' install | 38 | oe_runmake 'DESTDIR=${D}' install |
37 | install -d ${D}${bindir}/ | 39 | install -d ${D}${bindir}/${PN} |
38 | install -m 0755 Parser/pgen ${D}${bindir}/ | 40 | install -m 0755 Parser/pgen ${D}${bindir}/${PN} |
39 | 41 | ||
40 | # Make sure we use /usr/bin/env python | 42 | # Make sure we use /usr/bin/env python |
41 | for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do | 43 | for PYTHSCRIPT in `grep -rIl ${bindir}/${PN}/python ${D}${bindir}/${PN}`; do |
42 | sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT | 44 | sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT |
43 | done | 45 | done |
44 | } | 46 | } |