diff options
author | Nitin A Kamble <nitin.a.kamble@intel.com> | 2011-10-14 07:06:13 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-10-31 22:03:20 +0000 |
commit | 01103b2f299fd9aa05ecae40760c2011f235f710 (patch) | |
tree | 43ebed3560003af61dccfefeb2d3da4932ad7167 /meta/recipes-devtools/python/python-native_2.7.2.bb | |
parent | 0d18f03b225ffaffb1e17b40ff909f4948880647 (diff) | |
download | poky-01103b2f299fd9aa05ecae40760c2011f235f710.tar.gz |
python, python-native: upgrade from 2.6.6 to 2.7.2
Rebased these patches to the newer code
modified: python-native/nohostlibs.patch
modified: python/01-use-proper-tools-for-cross-build.patch
modified: python/06-avoid_usr_lib_termcap_path_in_linking.patch
modified: python/06-ctypes-libffi-fix-configure.patch
modified: python/multilib.patch
Deleted these patches are the are now upstream
deleted: python/02-remove-test-for-cross.patch
deleted: python/security_issue_2254_fix.patch
Added this patch to python-native
new file: python-native/multilib.patch
Updated site config file for python
modified: ../../site/common-linux : add ac_cv_have_long_long_format for python
avoid this error in python:
Include/pyport.h:243:13: error: #error "This platform's pyconfig.h needs to define PY_FORMAT_LONG_LONG"
Updated default python version
modified: ../../conf/distro/include/default-versions.inc
(From OE-Core rev: b284e9a512860b8a8380be80f96cebce6b92ff80)
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.2.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-native_2.7.2.bb | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.2.bb b/meta/recipes-devtools/python/python-native_2.7.2.bb new file mode 100644 index 0000000000..6b90d5b891 --- /dev/null +++ b/meta/recipes-devtools/python/python-native_2.7.2.bb | |||
@@ -0,0 +1,43 @@ | |||
1 | require python.inc | ||
2 | DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native" | ||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRC_URI += "file://04-default-is-optimized.patch \ | ||
6 | file://05-enable-ctypes-cross-build.patch \ | ||
7 | file://06-ctypes-libffi-fix-configure.patch \ | ||
8 | file://10-distutils-fix-swig-parameter.patch \ | ||
9 | file://11-distutils-never-modify-shebang-line.patch \ | ||
10 | file://12-distutils-prefix-is-inside-staging-area.patch \ | ||
11 | file://debug.patch \ | ||
12 | file://unixccompiler.patch \ | ||
13 | file://nohostlibs.patch \ | ||
14 | file://multilib.patch " | ||
15 | S = "${WORKDIR}/Python-${PV}" | ||
16 | |||
17 | inherit native | ||
18 | |||
19 | EXTRA_OEMAKE = '\ | ||
20 | BUILD_SYS="" \ | ||
21 | HOST_SYS="" \ | ||
22 | LIBC="" \ | ||
23 | STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \ | ||
24 | STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \ | ||
25 | ' | ||
26 | |||
27 | do_configure_prepend() { | ||
28 | autoreconf --verbose --install --force --exclude=autopoint Modules/_ctypes/libffi || bbnote "_ctypes failed to autoreconf" | ||
29 | } | ||
30 | |||
31 | do_install() { | ||
32 | oe_runmake 'DESTDIR=${D}' install | ||
33 | install -d ${D}${bindir}/ | ||
34 | install -m 0755 Parser/pgen ${D}${bindir}/ | ||
35 | |||
36 | # Make sure we use /usr/bin/env python | ||
37 | for PYTHSCRIPT in `grep -rIl ${bindir}/python ${D}${bindir}`; do | ||
38 | sed -i -e '1s|^#!.*|#!/usr/bin/env python|' $PYTHSCRIPT | ||
39 | done | ||
40 | |||
41 | ln -sf python ${D}${bindir}/python2 | ||
42 | |||
43 | } | ||