summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-native_2.7.2.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2011-11-27 17:22:37 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-29 11:22:05 +0000
commit31e998266f8671b330745f29cf1be9931685abb0 (patch)
tree43a9490555f4fce811b7dbe7529c24d476c033dc /meta/recipes-devtools/python/python-native_2.7.2.bb
parentfbdbe8d1ec6ca269c5121a45d4684449664b6d5d (diff)
downloadpoky-31e998266f8671b330745f29cf1be9931685abb0.tar.gz
python-native: Fix gcc compiler detecting logic
We have a patch unixccompiler.patch where we try to throw away everything except first element of CC string but this does not work if gcc is prepended with something e.g. CC="ccache gcc" then the logic fails and it ends up in some modules failing on you silently (_sqlite3) in my case. The fix here is to drop basename so we keep the whole string as it is and then the detection function searches for gcc string in the whole CC. This works in both cases one the original intent of the patch and the second described above. One place where it will fail is if someone has non-gcc compiler installed in some subdir which has gcc in it e.g. /usr/gcc/fakecc but for OE this should never happen. Ideally the the detection logic should have tried to execute gcc and then parsed --version output or something. (From OE-Core rev: 9b13b9024d24953dedb35f62d3d8b06a29036992) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-native_2.7.2.bb')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.2.bb b/meta/recipes-devtools/python/python-native_2.7.2.bb
index 6b90d5b891..d036eca976 100644
--- a/meta/recipes-devtools/python/python-native_2.7.2.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.2.bb
@@ -1,6 +1,6 @@
1require python.inc 1require python.inc
2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native" 2DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native sqlite3-native"
3PR = "${INC_PR}.0" 3PR = "${INC_PR}.1"
4 4
5SRC_URI += "file://04-default-is-optimized.patch \ 5SRC_URI += "file://04-default-is-optimized.patch \
6 file://05-enable-ctypes-cross-build.patch \ 6 file://05-enable-ctypes-cross-build.patch \