summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-git_1.0.1.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-27 22:27:23 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-30 22:26:11 +0100
commitdf093b3308f13be7a59c73d587522be012de8e8d (patch)
tree8cfbba132e96f1b037cac3cb10243090358af1f2 /meta/recipes-devtools/python/python-git_1.0.1.bb
parent1b193fd10be9b7051e435f81703ae7a5e74fcbdd (diff)
downloadpoky-df093b3308f13be7a59c73d587522be012de8e8d.tar.gz
python-git: 1.0.0 -> 1.0.1
(From OE-Core rev: 2299b06c78b762d1ac08c18c724ffd1e7cc6a3c0) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-git_1.0.1.bb')
-rw-r--r--meta/recipes-devtools/python/python-git_1.0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_1.0.1.bb b/meta/recipes-devtools/python/python-git_1.0.1.bb
new file mode 100644
index 0000000000..a78d7c83c4
--- /dev/null
+++ b/meta/recipes-devtools/python/python-git_1.0.1.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10DEPENDS = "python-gitdb"
11
12SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "4659644b42c41e5e5170c0cd83ed6422"
15SRC_URI[sha256sum] = "9c88c17bbcae2a445ff64024ef13526224f70e35e38c33416be5ceb56ca7f760"
16
17S = "${WORKDIR}/GitPython-${PV}"
18
19inherit setuptools
20
21RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold"
22
23BBCLASSEXTEND = "nativesdk"