summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python/python-git_0.3.3.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-01-07 15:52:59 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-01-16 23:08:21 +0000
commit3996f7a46f1036805484cf05aa8481870d66ab60 (patch)
tree1c3ee592ec3e3255bb211143e64619921b542d0b /meta/recipes-devtools/python/python-git_0.3.3.bb
parentb39ebfd9b29a0c92bd5252ca35500d8378ac92d9 (diff)
downloadpoky-3996f7a46f1036805484cf05aa8481870d66ab60.tar.gz
python-git: upgrade to 0.3.3
(From OE-Core rev: 70ca4ede24cd45057992580ab1a81e803a49a68b) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-git_0.3.3.bb')
-rw-r--r--meta/recipes-devtools/python/python-git_0.3.3.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-git_0.3.3.bb b/meta/recipes-devtools/python/python-git_0.3.3.bb
new file mode 100644
index 0000000000..860c37bf99
--- /dev/null
+++ b/meta/recipes-devtools/python/python-git_0.3.3.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Python library used to interact with Git repositories"
2DESCRIPTION = "GitPython provides object model read and write access to \
3a git repository. Access repository information conveniently, alter the \
4index directly, handle remotes, or go down to low-level object database \
5access with big-files support."
6HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
7SECTION = "devel/python"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8b8d26c37c1d5a04f9b0186edbebc183"
10DEPENDS = "python-gitdb"
11
12SRC_URI = "http://pypi.python.org/packages/source/G/GitPython/GitPython-${PV}.tar.gz"
13
14SRC_URI[md5sum] = "c9fdde02c476c11168fd620659496aba"
15SRC_URI[sha256sum] = "08193acf4e22b57a471cde3748ebce7c17e0f15f1e5042db74ca2c5e9e3e4db5"
16
17S = "${WORKDIR}/GitPython-${PV}"
18
19inherit setuptools
20
21RDEPENDS_${PN} += "python-gitdb python-lang python-io python-shell python-math python-re python-subprocess python-stringold"
22
23BBCLASSEXTEND = "nativesdk"