diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-03-09 22:10:50 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-02-02 22:37:39 +0000 |
commit | aacfd003d5670e14ee862619fb5413befa66eea0 (patch) | |
tree | b8e67d222e8c92af335d5ca845f3ee90b48f576a /meta/recipes-devtools/python/python-distribute_0.6.32.bb | |
parent | 6a539a7f73f8a3672b8b32b519621184616b2519 (diff) | |
download | poky-aacfd003d5670e14ee862619fb5413befa66eea0.tar.gz |
python-distribute: Add recipes for python2 and python3
in python3-distribute rename easy_install to easy3_install
(From OE-Core rev: 712d65335b9a92bba427949f8885102d0aefbeb4)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python/python-distribute_0.6.32.bb')
-rw-r--r-- | meta/recipes-devtools/python/python-distribute_0.6.32.bb | 47 |
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-distribute_0.6.32.bb b/meta/recipes-devtools/python/python-distribute_0.6.32.bb new file mode 100644 index 0000000000..86ac8718a9 --- /dev/null +++ b/meta/recipes-devtools/python/python-distribute_0.6.32.bb | |||
@@ -0,0 +1,47 @@ | |||
1 | DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages" | ||
2 | HOMEPAGE = "http://packages.python.org/distribute" | ||
3 | SECTION = "devel/python" | ||
4 | LICENSE = "PSF" | ||
5 | LIC_FILES_CHKSUM = "file://setup.py;beginline=234;endline=234;md5=26f6b02022b737126d3c88838782dddb" | ||
6 | |||
7 | SRCNAME = "distribute" | ||
8 | PR = "ml5" | ||
9 | DEPENDS += "python" | ||
10 | DEPENDS_virtclass-native += "python-native" | ||
11 | |||
12 | SRC_URI = " \ | ||
13 | http://pypi.python.org/packages/source/d/distribute/${SRCNAME}-${PV}.tar.gz \ | ||
14 | " | ||
15 | S = "${WORKDIR}/${SRCNAME}-${PV}" | ||
16 | |||
17 | # http://python-distribute.org/distribute_setup.py | ||
18 | |||
19 | # force the selection of python3 | ||
20 | #PYTHON_BASEVERSION = "3.3" | ||
21 | #PYTHON_MAJMIN = "3.3" | ||
22 | |||
23 | inherit distutils | ||
24 | |||
25 | DISTUTILS_INSTALL_ARGS += "--install-lib=${D}${libdir}/${PYTHON_DIR}/site-packages" | ||
26 | |||
27 | do_install_prepend() { | ||
28 | install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages | ||
29 | } | ||
30 | |||
31 | # | ||
32 | # The installer puts the wrong path in the setuptools.pth file. Correct it. | ||
33 | # | ||
34 | do_install_append() { | ||
35 | rm ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth | ||
36 | echo "./${SRCNAME}-${PV}-py${PYTHON_BASEVERSION}.egg" > ${D}${PYTHON_SITEPACKAGES_DIR}/setuptools.pth | ||
37 | } | ||
38 | |||
39 | RDEPENDS_${PN} = "\ | ||
40 | python-distutils \ | ||
41 | python-compression \ | ||
42 | " | ||
43 | |||
44 | SRC_URI[md5sum] = "acb7a2da81e3612bfb1608abe4f0e568" | ||
45 | SRC_URI[sha256sum] = "8970cd1e148b5d1fea9430584aea66c45ea22d80e0933393ec49ebc388f718df" | ||
46 | |||
47 | BBCLASSEXTEND = "native" | ||