summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-09 07:19:21 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-13 09:27:38 +0100
commit9b32a558f663502d119b94264fa6cfa98086cb52 (patch)
treead94e8731c3f894960fa533a280be7b7deaa8f7e /meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb
parent43d52e785b42a9b38419ae2959cc5983bd017deb (diff)
downloadpoky-9b32a558f663502d119b94264fa6cfa98086cb52.tar.gz
python-numpy: Upgrade to 1.13.1
Update LICENSE to BSD-3-Clause as per https://github.com/numpy/numpy/blob/master/LICENSE.txt LIC_FILES_CHKSUM changed due to copyright year change see https://github.com/numpy/numpy/commit/b2ff4f13197dd58508d3d025a9034519974750bd (From OE-Core rev: a703bb6159dd69020fb40db7a6a0811f45869972) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb')
-rw-r--r--meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb113
1 files changed, 113 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb b/meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb
new file mode 100644
index 0000000000..0bf9e914f9
--- /dev/null
+++ b/meta/recipes-devtools/python-numpy/python3-numpy_1.13.1.bb
@@ -0,0 +1,113 @@
1SUMMARY = "A sophisticated Numeric Processing Package for Python"
2SECTION = "devel/python"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=1002b09cd654fcaa2dcc87535acd9a96"
5
6SRCNAME = "numpy"
7
8SRC_URI = "https://github.com/${SRCNAME}/${SRCNAME}/releases/download/v${PV}/${SRCNAME}-${PV}.tar.gz \
9 file://0001-Don-t-search-usr-and-so-on-for-libraries-by-default-.patch \
10 file://remove-build-path-in-comments.patch \
11 file://fix_shebang_f2py.patch \
12 ${CONFIGFILESURI} "
13SRC_URI[md5sum] = "6d459e4a24f5035f720dda3c57716a92"
14SRC_URI[sha256sum] = "de020ec06f1e9ce1115a50161a38bf8d4c2525379900f9cb478cc613a1e7cd93"
15
16UPSTREAM_CHECK_URI = "https://github.com/numpy/numpy/releases"
17
18CONFIGFILESURI ?= ""
19
20CONFIGFILESURI_aarch64 = " \
21 file://config.h \
22 file://_numpyconfig.h \
23"
24CONFIGFILESURI_arm = " \
25 file://config.h \
26 file://numpyconfig.h \
27"
28CONFIGFILESURI_armeb = " \
29 file://config.h \
30 file://numpyconfig.h \
31"
32CONFIGFILESURI_mipsarcho32el = " \
33 file://config.h \
34 file://numpyconfig.h \
35"
36CONFIGFILESURI_x86 = " \
37 file://config.h \
38 file://numpyconfig.h \
39"
40CONFIGFILESURI_x86-64 = " \
41 file://config.h \
42 file://_numpyconfig.h \
43"
44CONFIGFILESURI_mipsarcho32eb = " \
45 file://config.h \
46 file://_numpyconfig.h \
47"
48CONFIGFILESURI_powerpc = " \
49 file://config.h \
50 file://_numpyconfig.h \
51"
52CONFIGFILESURI_powerpc64 = " \
53 file://config.h \
54 file://_numpyconfig.h \
55"
56CONFIGFILESURI_mipsarchn64eb = " \
57 file://config.h \
58 file://_numpyconfig.h \
59"
60CONFIGFILESURI_mipsarchn64el = " \
61 file://config.h \
62 file://_numpyconfig.h \
63"
64CONFIGFILESURI_mipsarchn32eb = " \
65 file://config.h \
66 file://_numpyconfig.h \
67"
68CONFIGFILESURI_mipsarchn32el = " \
69 file://config.h \
70 file://_numpyconfig.h \
71"
72
73S = "${WORKDIR}/numpy-${PV}"
74
75inherit setuptools3
76
77# Make the build fail and replace *config.h with proper one
78# This is a ugly, ugly hack - Koen
79do_compile_prepend_class-target() {
80 ${STAGING_BINDIR_NATIVE}/python3-native/python3 setup.py build ${DISTUTILS_BUILD_ARGS} || \
81 true
82 cp ${WORKDIR}/*config.h ${S}/build/$(ls ${S}/build | grep src)/numpy/core/include/numpy/
83}
84
85FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
86
87# install what is needed for numpy.test()
88RDEPENDS_${PN} = "python3-unittest \
89 python3-difflib \
90 python3-pprint \
91 python3-pickle \
92 python3-shell \
93 python3-nose \
94 python3-doctest \
95 python3-datetime \
96 python3-distutils \
97 python3-misc \
98 python3-mmap \
99 python3-netclient \
100 python3-numbers \
101 python3-pydoc \
102 python3-pkgutil \
103 python3-email \
104 python3-subprocess \
105 python3-compression \
106 python3-ctypes \
107 python3-threading \
108 python3-textutils \
109"
110
111RDEPENDS_${PN}_class-native = ""
112
113BBCLASSEXTEND = "native nativesdk"