summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_git.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2019-12-24 15:21:09 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-12-30 08:47:09 +0000
commit1bbc547a5ed545c1067e6b108877c6acc34437b6 (patch)
tree9215dfbd1596104277a7790170bec119df18ddac /meta/recipes-devtools/pseudo/pseudo_git.bb
parent0692b3877f76e8a4dcad331342de03f3e3e51012 (diff)
downloadpoky-1bbc547a5ed545c1067e6b108877c6acc34437b6.tar.gz
pseudo: Make realpath() remove trailing slashes
Linux system's realpath() remove trailing slashes, but pseudo's doesn't, need make them identical. E.g., the following code (rel.c) prints '/tmp' with system's realpath, but pseudo's realpath prints '/tmp/': #include <stdio.h> #include <limits.h> #include <stdlib.h> int main() { char out[PATH_MAX]; printf("%s\n", realpath("/tmp/", out)); return 0; } $ bitbake base-passwd -cdevshell # For pseudo env $ gcc rel.c $ ./a.out /tmp/ (but should be /tmp) This patch fixes the problem. (From OE-Core rev: 319bbf66e03377adf2db7efa93ef578e3460eb38) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_git.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_git.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_git.bb b/meta/recipes-devtools/pseudo/pseudo_git.bb
index 1f2df4a427..7c75293ef1 100644
--- a/meta/recipes-devtools/pseudo/pseudo_git.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_git.bb
@@ -8,6 +8,7 @@ SRC_URI = "git://git.yoctoproject.org/pseudo \
8 file://toomanyfiles.patch \ 8 file://toomanyfiles.patch \
9 file://0001-maketables-wrappers-use-Python-3.patch \ 9 file://0001-maketables-wrappers-use-Python-3.patch \
10 file://0001-Add-statx.patch \ 10 file://0001-Add-statx.patch \
11 file://0001-realpath.c-Remove-trailing-slashes.patch \
11 " 12 "
12 13
13SRCREV = "060058bb29f70b244e685b3c704eb0641b736f73" 14SRCREV = "060058bb29f70b244e685b3c704eb0641b736f73"