summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
diff options
context:
space:
mode:
authorPeter Seebach <peter.seebach@windriver.com>2016-02-09 13:57:58 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-10 17:37:41 +0000
commit7cd835177ae0208859f790c0c638cde908386d5c (patch)
tree624485de72b57418ed182cb806c78d7a12fecd45 /meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
parent246b02e281f84ffe1c9156ce24b728eb6f3742c1 (diff)
downloadpoky-7cd835177ae0208859f790c0c638cde908386d5c.tar.gz
pseudo: uprev to 1.7.5
This uprev adds various improvements with regards to the server spawn logic, and also sorts xattrs to work around a bug in one of the mkfs utilities. (From OE-Core rev: 4bd658f7dae76ae8790fd1dfdd89fa58a456a0a4) Signed-off-by: Peter Seebach <peter.seebach@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_1.7.5.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.7.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb b/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
new file mode 100644
index 0000000000..195a50878b
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.7.5.bb
@@ -0,0 +1,19 @@
1require pseudo.inc
2
3SRC_URI = " \
4 http://downloads.yoctoproject.org/releases/pseudo/${BPN}-${PV}.tar.bz2 \
5 file://fallback-passwd \
6 file://fallback-group \
7"
8
9SRC_URI[md5sum] = "c10209938f03128d0c193f041ff3596d"
10SRC_URI[sha256sum] = "fd89cadec984d3b8202aca465898b1bb4350e0d63ba9aa9ac899f6f50270e688"
11
12PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
13
14do_install_append_class-native () {
15 install -d ${D}${sysconfdir}
16 # The fallback files should never be modified
17 install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
18 install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
19}