summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
diff options
context:
space:
mode:
authorPeter Seebach <peter.seebach@windriver.com>2015-05-04 15:55:49 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-05 22:15:17 +0100
commit08d78e01fade4bc04fdfd1750b8b0abc6885d9af (patch)
tree5b9a078d40b8b6276e88e64acb527ebfa2b40d89 /meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
parenteb4306e4b2739efdd1e34af89f36546fa0c6c834 (diff)
downloadpoky-08d78e01fade4bc04fdfd1750b8b0abc6885d9af.tar.gz
pseudo 1.6.5: less pointlessly chatty
There was a stupid logic error controlling the diagnostic for a "possible" mismatch involving trailing slashes and whether or not a node was believed to be a directory. Specifically, a diagnostic got printed any time a lookup for a directory *didn't* have a trailing slash, as well as in the (actually intended) case where a non-directory lookup *did*. No other changes, but that one is probably significant. (From OE-Core rev: f1d086bb7204ad37160e814eaf2504dc867cabff) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pseudo/pseudo_1.6.5.bb')
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.6.5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb b/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
new file mode 100644
index 0000000000..2a9dc63d03
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo_1.6.5.bb
@@ -0,0 +1,19 @@
1require pseudo.inc
2
3SRC_URI = " \
4 http://www.yoctoproject.org/downloads/${BPN}/${BPN}-${PV}.tar.bz2 \
5 file://fallback-passwd \
6 file://fallback-group \
7"
8
9SRC_URI[md5sum] = "a5545ff365e243193c81981df98e870b"
10SRC_URI[sha256sum] = "f5a0af976c958915503f516dd02097ab6a64c98a3c0cb4ceb0ce8b1ef8e38b3c"
11
12PSEUDO_EXTRA_OPTS ?= "--enable-force-async --without-passwd-fallback"
13
14do_install_append_class-native () {
15 install -d ${D}${sysconfdir}
16 # The fallback files should never be modified
17 install -m 444 ${WORKDIR}/fallback-passwd ${D}${sysconfdir}/passwd
18 install -m 444 ${WORKDIR}/fallback-group ${D}${sysconfdir}/group
19}