summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/prelink/prelink_git.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-devtools/prelink/prelink_git.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/prelink/prelink_git.bb')
-rw-r--r--meta/recipes-devtools/prelink/prelink_git.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/prelink/prelink_git.bb b/meta/recipes-devtools/prelink/prelink_git.bb
new file mode 100644
index 0000000000..06078ed68b
--- /dev/null
+++ b/meta/recipes-devtools/prelink/prelink_git.bb
@@ -0,0 +1,50 @@
1SECTION = "devel"
2# Need binutils for libiberty.a
3DEPENDS = "elfutils binutils"
4DESCRIPTION = " The prelink package contains a utility which modifies ELF shared libraries \
5and executables, so that far fewer relocations need to be resolved at \
6runtime and thus programs come up faster."
7LICENSE = "GPLv2"
8PV = "1.0+git${SRCPV}"
9PR = "r0"
10
11SRC_URI = "git://git.pokylinux.org/prelink-cross.git;protocol=git \
12 file://prelink.conf \
13 file://prelink.cron.daily \
14 file://prelink.default"
15
16TARGET_OS_ORIG := "${TARGET_OS}"
17OVERRIDES_append = ":${TARGET_OS_ORIG}"
18
19S = "${WORKDIR}/git/trunk"
20
21inherit autotools
22
23BBCLASSEXTEND = "native"
24
25EXTRA_OECONF = "--disable-selinux --with-pkgversion=${PV}-${PR} \
26 --with-bugurl=http://bugzilla.pokylinux.org/"
27
28do_install_append () {
29 install -d ${D}${sysconfdir}/cron.daily ${D}${sysconfdir}/default
30 install -m 0644 ${WORKDIR}/prelink.conf ${D}${sysconfdir}/prelink.conf
31 install -m 0644 ${WORKDIR}/prelink.cron.daily ${D}${sysconfdir}/cron.daily/prelink
32 install -m 0644 ${WORKDIR}/prelink.default ${D}${sysconfdir}/default/prelink
33}
34
35pkg_postinst_prelink() {
36#!/bin/sh
37
38if [ "x$D" != "x" ]; then
39 exit 1
40fi
41
42prelink -a
43}
44
45pkg_postrm_prelink() {
46#!/bin/sh
47
48prelink -au
49}
50