summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2014-11-13 09:54:14 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-20 14:08:14 +0000
commit0f5d0e98f6b77a768ee6b77646d0351401d49f0d (patch)
treea6b30bdf351ba90fbc390d069de12c337c4ac785 /meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
parent9ca077710f95da8a85f343525a2a44d3b3e4001d (diff)
downloadpoky-0f5d0e98f6b77a768ee6b77646d0351401d49f0d.tar.gz
postinst-intercept: rename recipe for nativesdk only
The recipe postinst-intercept is only used for nativesdk, so we rename it from postinst-intercept to nativesdk-postinst-intercept. It avoids unnecessary build of postinst-intercept. [YOCTO #6937] (From OE-Core rev: 6a320d07e45d9c41a6b50b96ba7f910cc141a1dd) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb')
-rw-r--r--meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb b/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
new file mode 100644
index 0000000000..7dc45c68f2
--- /dev/null
+++ b/meta/recipes-devtools/postinst-intercept/nativesdk-postinst-intercept_1.0.bb
@@ -0,0 +1,19 @@
1SUMMARY = "Postinstall scriptlets"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5FILES_${PN}_append = " ${datadir}/postinst-intercepts/*"
6
7do_configure[noexec] = "1"
8do_compile[noexec] = "1"
9
10do_install() {
11 install -d ${D}${datadir}/postinst-intercepts
12 install -m 755 ${COREBASE}/scripts/postinst-intercepts/postinst_intercept ${D}${datadir}/postinst-intercepts/
13 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_font_cache ${D}${datadir}/postinst-intercepts/
14 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_icon_cache ${D}${datadir}/postinst-intercepts/
15 install -m 755 ${COREBASE}/scripts/postinst-intercepts/update_pixbuf_cache ${D}${datadir}/postinst-intercepts/
16}
17
18inherit nativesdk
19INHIBIT_DEFAULT_DEPS = "1"