diff options
author | Khem Raj <raj.khem@gmail.com> | 2015-04-23 20:35:30 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-04-27 14:59:50 +0100 |
commit | 3ec67a951ebd670261fb1fd61f6bd043c6ec9573 (patch) | |
tree | 166a1aa829ed66afb5f1a77b6b44a23434706a9a /meta/recipes-devtools/pkgconfig/pkgconfig_git.bb | |
parent | 2a14041f3c3296d22dae44f980318e836a9bf502 (diff) | |
download | poky-3ec67a951ebd670261fb1fd61f6bd043c6ec9573.tar.gz |
pkgconfig: Upgrade to latest git tip
0.28 was released 2 years ago and bunch of patches
have gone in since. The commit rate is quite low
so its not a lot of churn to use. We have backports
for few bugs that are removed. Git version of recipe is removed too
since its no longer needed
Change-Id: I4b57db15320c76b1de5d26a733e60436663ff34a
(From OE-Core rev: c7478e328f6507350b7d2d2c790b3dd2bfe2d832)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pkgconfig/pkgconfig_git.bb')
-rw-r--r-- | meta/recipes-devtools/pkgconfig/pkgconfig_git.bb | 42 |
1 files changed, 4 insertions, 38 deletions
diff --git a/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb b/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb index e420420ae1..eaa511a8b7 100644 --- a/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb +++ b/meta/recipes-devtools/pkgconfig/pkgconfig_git.bb | |||
@@ -1,40 +1,6 @@ | |||
1 | require pkgconfig.inc | 1 | require pkgconfig.inc |
2 | 2 | ||
3 | SRC_URI = "git://anongit.freedesktop.org/pkg-config \ | 3 | SRC_URI += " \ |
4 | file://autofoo.patch" | 4 | file://pkg-config-native.in \ |
5 | 5 | file://fix-glib-configure-libtool-usage.patch \ | |
6 | S = "${WORKDIR}/git/" | 6 | " |
7 | |||
8 | SRCREV = "66d49f1375fec838bcd301bb4ca2ef76cee0e47c" | ||
9 | PV = "0.23+git${SRCPV}" | ||
10 | PR = "r1" | ||
11 | |||
12 | DEFAULT_PREFERENCE = "-1" | ||
13 | |||
14 | # Can't do native version with git since git-native depends on pkgconfig-native | ||
15 | BBCLASSEXTEND = "nativesdk" | ||
16 | |||
17 | do_fixsource() { | ||
18 | # Adapted from autogen.sh | ||
19 | cd ${S} | ||
20 | tar -xvzf glib-1.2.10.tar.gz | ||
21 | |||
22 | chmod +w `find glib-1.2.10 -name Makefile.am` | ||
23 | perl -p -i.bak -e "s/lib_LTLIBRARIES/noinst_LTLIBRARIES/g" `find glib-1.2.10 -name Makefile.am` | ||
24 | perl -p -i.bak -e "s/bin_SCRIPTS/noinst_SCRIPTS/g" `find glib-1.2.10 -name Makefile.am` | ||
25 | perl -p -i.bak -e "s/include_HEADERS/noinst_HEADERS/g" `find glib-1.2.10 -name Makefile.am` | ||
26 | perl -p -i.bak -e "s/glibnoinst_HEADERS/noinst_HEADERS/g" `find glib-1.2.10 -name Makefile.am` | ||
27 | perl -p -i.bak -e 's/([a-zA-Z0-9]+)_DATA/noinst_DATA/g' `find glib-1.2.10 -name Makefile.am` | ||
28 | perl -p -i.bak -e "s/info_TEXINFOS/noinst_TEXINFOS/g" `find glib-1.2.10 -name Makefile.am` | ||
29 | perl -p -i.bak -e "s/man_MANS/noinst_MANS/g" `find glib-1.2.10 -name Makefile.am` | ||
30 | |||
31 | ## patch gslist.c to have stable sort | ||
32 | perl -p -w -i.bak -e 's/if \(compare_func\(l1->data,l2->data\) < 0\)/if \(compare_func\(l1->data,l2->data\) <= 0\)/g' glib-1.2.10/gslist.c | ||
33 | |||
34 | # Update random auto* files to actually have something which have a snowball's | ||
35 | # chance in a hot place of working with modern auto* tools. | ||
36 | |||
37 | (cd glib-1.2.10 && for p in ../glib-patches/*.diff; do echo $p; patch -p1 < $p || exit 1; done ) || exit 1 | ||
38 | } | ||
39 | |||
40 | addtask fixsource before do_patch after do_unpack | ||