summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorVenkata ramana gollamudi <ramana.gollamudi@huawei.com>2012-04-17 09:04:15 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-17 12:26:12 +0100
commit8cc3b24242624b3ec750db3a09262fe14efb0193 (patch)
tree16815aa9f3d387451b355fe8897ec8c562801deb /meta/recipes-devtools/perl/perl_5.14.2.bb
parent6004dc8906f6a36f6242a96b94efd111d474d2cf (diff)
downloadpoky-8cc3b24242624b3ec750db3a09262fe14efb0193.tar.gz
perl: fix re-execution of compile task
After building perl package, re-execution of compile task recursively substitutes the path, making it an invalid path. Fixed to prevent recursive substitution. Similar case as [Yocto #2194] (From OE-Core rev: 16542d982d86d42d3189d47a8180f0f71646a9ca) Signed-off-by: Venkata Ramana Gollamudi <ramana.gollamudi@huawei.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index ecb2262796..809fc72d33 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -174,8 +174,9 @@ do_configure() {
174} 174}
175 175
176do_compile() { 176do_compile() {
177 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL 177 # Fix to avoid recursive substitution of path
178 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' cpan/Compress-Raw-Zlib/config.in 178 sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" ext/Errno/Errno_pm.PL
179 sed -i -e "s|\([ \"\']\+\)/usr/include|\1${STAGING_INCDIR}|g" cpan/Compress-Raw-Zlib/config.in
179 sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in 180 sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
180 sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm 181 sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
181 182