summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@intel.com>2012-10-09 19:48:24 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-10 15:24:13 +0100
commit784f93baf3fe1ea77026edafc890fb7dc2e83794 (patch)
tree597552e9655515ac8f53a09b67d191335237ff6e /meta/recipes-devtools/perl/perl_5.14.2.bb
parent755ca76f8ec10278cb809d4e9566569796fdd747 (diff)
downloadpoky-784f93baf3fe1ea77026edafc890fb7dc2e83794.tar.gz
perl: add archlib_exp variable used to generate ARCHLIB_EXP in config.h
perl.c uses an ARCHLIB_EXP define to generate compile-time code that adds the archlibexp path to @INC during run-time initialization of a new perl interpreter. Because we've changed this value in a temporary way to make it possible to use ExtUtils::Embed in the target build (the temporary value in config.sh gets re-stripped out during packaging), the ARCHLIB_EXP value that gets generated still uses the temporary version instead of the original expected version (i.e. becauses it's in the generated config.h, it doesn't get stripped out during packaging like the others in config.sh). This creates an unmodified version called archlib_exp that gets used by a modified config_h.SH to get the correct value into config.h This patch uses an unmodified version of archlibexp called archlib_exp, introduced to config.sh, which is used to generate the correct value of ARCHLIB_EXP into config.h Fixes [YOCTO #3099]. (From OE-Core rev: cbcfdeb1d55e2e76f199750bda401bad126ae234) Signed-off-by: Tom Zanussi <tom.zanussi@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 09b2acb191..d9206d86d3 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
7# We need gnugrep (for -I) 7# We need gnugrep (for -I)
8DEPENDS = "virtual/db grep-native" 8DEPENDS = "virtual/db grep-native"
9DEPENDS += "gdbm zlib" 9DEPENDS += "gdbm zlib"
10PR = "r10" 10PR = "r11"
11 11
12# 5.10.1 has Module::Build built-in 12# 5.10.1 has Module::Build built-in
13PROVIDES += "libmodule-build-perl" 13PROVIDES += "libmodule-build-perl"
@@ -66,6 +66,7 @@ SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
66 file://cross-generate_uudmap.patch \ 66 file://cross-generate_uudmap.patch \
67 file://fix_bad_rpath.patch \ 67 file://fix_bad_rpath.patch \
68 file://perl-build-in-t-dir.patch \ 68 file://perl-build-in-t-dir.patch \
69 file://perl-archlib-exp.patch \
69 \ 70 \
70 file://config.sh \ 71 file://config.sh \
71 file://config.sh-32 \ 72 file://config.sh-32 \