summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-10-19 14:53:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-24 17:27:14 +0100
commit5f8f114e4cc29e96942f96ef7dec6d25e18b6d4f (patch)
tree5b7867dec533d001ce29d8bf7b4869299cea254f /meta/recipes-devtools/perl/perl_5.14.2.bb
parent53f7342562a66d1b14ecee234aa76be07951dedc (diff)
downloadpoky-5f8f114e4cc29e96942f96ef7dec6d25e18b6d4f.tar.gz
perl: upgrade from 5.12.3 to 5.14.2
parallel build fix patches are not needed as they are upstream now. Got a new set of debian patch set for 5.14.2 perl-rpdepends: fix the autogenerated rdepends mistakes take out some mdoules which are not going to be built. [Saul Wold: Remove debug] (From OE-Core rev: 8dc5f118832a4aca906239ffed82f72497c37f8e) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb304
1 files changed, 304 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
new file mode 100644
index 0000000000..788962638d
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -0,0 +1,304 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "devel"
4LICENSE = "Artistic|GPL"
5LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
6 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
7# We need gnugrep (for -I)
8DEPENDS = "virtual/db grep-native"
9DEPENDS += "gdbm zlib"
10PR = "r0"
11
12# 5.10.1 has Module::Build built-in
13PROVIDES += "libmodule-build-perl"
14
15SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
16 file://debian/arm_thread_stress_timeout.diff \
17 file://debian/cpan_definstalldirs.diff \
18 file://debian/db_file_ver.diff \
19 file://debian/doc_info.diff \
20 file://debian/enc2xs_inc.diff \
21 file://debian/errno_ver.diff \
22 file://debian/libperl_embed_doc.diff \
23 file://debian/fixes/respect_umask.diff \
24 file://debian/writable_site_dirs.diff \
25 file://debian/extutils_set_libperl_path.diff \
26 file://debian/no_packlist_perllocal.diff \
27 file://debian/prefix_changes.diff \
28 file://debian/fakeroot.diff \
29 file://debian/instmodsh_doc.diff \
30 file://debian/ld_run_path.diff \
31 file://debian/libnet_config_path.diff \
32 file://debian/m68k_thread_stress.diff \
33 file://debian/mod_paths.diff \
34 file://debian/module_build_man_extensions.diff \
35 file://debian/prune_libs.diff \
36 file://debian/fixes/net_smtp_docs.diff \
37 file://debian/perlivp.diff \
38 file://debian/disable-zlib-bundling.diff \
39 file://debian/cpanplus_definstalldirs.diff \
40 file://debian/cpanplus_config_path.diff \
41 file://debian/deprecate-with-apt.diff \
42 file://debian/fixes/hurd-ccflags.diff \
43 file://debian/squelch-locale-warnings.diff \
44 file://debian/skip-upstream-git-tests.diff \
45 file://debian/fixes/extutils-cbuilder-cflags.diff \
46 file://debian/fixes/module-build-home-directory.diff \
47 file://debian/fixes/h2ph-multiarch.diff \
48 file://debian/fixes/index-tainting.diff \
49 file://debian/skip-kfreebsd-crash.diff \
50 file://debian/fixes/document_makemaker_ccflags.diff \
51 file://debian/fixes/sys-syslog-socket-timeout-kfreebsd.patch \
52 file://debian/fixes/hurd-hints.diff \
53 file://debian/fixes/pod_fixes.diff \
54 file://debian/find_html2text.diff \
55 \
56 file://Makefile.patch \
57 file://Makefile.SH.patch \
58 file://installperl.patch \
59 file://perl-dynloader.patch \
60 file://perl-moreconfig.patch \
61 file://letgcc-find-errno.patch \
62 file://generate-sh.patch \
63 file://09_fix_installperl.patch \
64 file://native-perlinc.patch \
65 file://perl-enable-gdbm.patch \
66 file://cross-generate_uudmap.patch \
67 file://fix_bad_rpath.patch \
68 \
69 file://config.sh \
70 file://config.sh-32 \
71 file://config.sh-32-le \
72 file://config.sh-32-be \
73 file://config.sh-64 \
74 file://config.sh-64-le \
75 file://config.sh-64-be"
76# file://debian/fakeroot.diff
77
78SRC_URI[md5sum] = "3306fbaf976dcebdcd49b2ac0be00eb9"
79SRC_URI[sha256sum] = "6488359573bd7d41761bf935f66f827dc220fb3df961ef9b775d51fbd66548d3"
80
81inherit perlnative siteinfo
82
83# Where to find the native perl
84HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl-native/perl${PV}"
85
86# Where to find .so files - use the -native versions not those from the target build
87export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
88
89# LDFLAGS for shared libraries
90export LDDLFLAGS = "${LDFLAGS} -shared"
91
92# We're almost Debian, aren't we?
93CFLAGS += "-DDEBIAN"
94
95do_nolargefile() {
96 sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
97 -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
98 -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
99 -e "/ccflags_uselargefiles/d" \
100 -e "s/-Duselargefiles//" \
101 -e "s/-D_FILE_OFFSET_BITS=64//" \
102 -e "s/-D_LARGEFILE_SOURCE//" \
103 ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
104}
105
106do_configure() {
107 # Make hostperl in build directory be the native perl
108 ln -sf ${HOSTPERL} hostperl
109
110 # Do our work in the cross subdir
111 cd Cross
112
113 # Generate configuration
114 rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
115 for i in ${WORKDIR}/config.sh \
116 ${WORKDIR}/config.sh-${SITEINFO_BITS} \
117 ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
118 cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
119 done
120
121 # Fixups for uclibc
122 if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
123 sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
124 -e "s,\(d_futimes=\)'define',\1'undef',g" \
125 -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
126 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
127 -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \
128 -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \
129 -e "s,\(getnetbyaddr_r_proto=\)'\w+',\1'0',g" \
130 -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \
131 -e "s,\(getnetent_r_proto=\)'\w+',\1'0',g" \
132 -e "s,\(d_sockatmark=\)'define',\1'undef',g" \
133 -e "s,\(d_sockatmarkproto=\)'\w+',\1'0',g" \
134 -e "s,\(d_eaccess=\)'define',\1'undef',g" \
135 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
136 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
137 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
138 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
139 -e "s,-fstack-protector,-fno-stack-protector,g" \
140 config.sh-${TARGET_ARCH}-${TARGET_OS}
141 fi
142
143 ${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
144
145 # Update some paths in the configuration
146 sed -i -e 's,@DESTDIR@,${prefix},g' \
147 -e 's,@ARCH@-thread-multi,,g' \
148 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
149 -e "s%/usr/include%${STAGING_INCDIR}%g" \
150 -e 's,/usr/lib/,${libdir}/,g' \
151 -e 's,/usr/,${exec_prefix}/,g' \
152 -e 's,/perl5,/perl,g' \
153 config.sh-${TARGET_ARCH}-${TARGET_OS}
154
155 case "${TARGET_ARCH}" in
156 x86_64 | powerpc | s390)
157 sed -i -e "s,\(need_va_copy=\)'undef',\1'define',g" \
158 config.sh-${TARGET_ARCH}-${TARGET_OS}
159 ;;
160 arm)
161 sed -i -e "s,\(d_u32align=\)'undef',\1'define',g" \
162 config.sh-${TARGET_ARCH}-${TARGET_OS}
163 ;;
164 esac
165 # These are strewn all over the source tree
166 for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
167 echo Fixing: $foo
168 sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
169 done
170
171 rm -f config
172 echo "ARCH = ${TARGET_ARCH}" > config
173 echo "OS = ${TARGET_OS}" >> config
174}
175
176do_compile() {
177 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
178 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' cpan/Compress-Raw-Zlib/config.in
179 sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
180 sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
181
182 cd Cross
183 oe_runmake perl LD="${CCLD}"
184}
185
186do_install() {
187 oe_runmake install DESTDIR=${D}
188 # Add perl pointing at current version
189 ln -sf perl${PV} ${D}${bindir}/perl
190
191 ln -sf perl ${D}/${libdir}/perl5
192
193 # Remove unwanted file
194 rm -f ${D}/${libdir}/perl/${PV}/.packlist
195
196 # Fix up shared library
197 mv ${D}/${libdir}/perl/${PV}/CORE/libperl.so ${D}/${libdir}/libperl.so.${PV}
198 ln -sf libperl.so.${PV} ${D}/${libdir}/libperl.so.5
199
200 # target config, used by cpan.bbclass to extract version information
201 install config.sh ${D}${libdir}/perl
202
203 ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl
204
205}
206
207PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
208
209perl_package_preprocess () {
210 # Fix up installed configuration
211 sed -i -e "s,${D},,g" \
212 -e "s,-isystem${STAGING_INCDIR} ,,g" \
213 -e "s,${STAGING_LIBDIR},${libdir},g" \
214 -e "s,${STAGING_BINDIR},${bindir},g" \
215 -e "s,${STAGING_INCDIR},${includedir},g" \
216 -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
217 -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
218 ${PKGD}${bindir}/h2xs \
219 ${PKGD}${bindir}/h2ph \
220 ${PKGD}${bindir}/pod2man \
221 ${PKGD}${bindir}/pod2text \
222 ${PKGD}${bindir}/pod2usage \
223 ${PKGD}${bindir}/podchecker \
224 ${PKGD}${bindir}/podselect \
225 ${PKGD}${libdir}/perl/${PV}/pod/*.pod \
226 ${PKGD}${libdir}/perl/${PV}/cacheout.pl \
227 ${PKGD}${libdir}/perl/${PV}/FileCache.pm \
228 ${PKGD}${libdir}/perl/config.sh \
229 ${PKGD}${libdir}/perl/${PV}/Config.pm \
230 ${PKGD}${libdir}/perl/${PV}/Config_heavy.pl \
231 ${PKGD}${libdir}/perl/${PV}/CORE/perl.h \
232 ${PKGD}${libdir}/perl/${PV}/CORE/pp.h
233}
234
235PACKAGES = "perl-dbg perl perl-misc perl-dev perl-pod perl-doc perl-lib \
236 perl-module-cpan perl-module-cpanplus perl-module-unicore"
237FILES_${PN} = "${bindir}/perl ${bindir}/perl${PV}"
238FILES_${PN}-dev = "${libdir}/perl/${PV}/CORE"
239FILES_${PN}-lib = "${libdir}/libperl.so* \
240 ${libdir}/perl5 \
241 ${libdir}/perl/config.sh \
242 ${libdir}/perl/${PV}/Config_heavy.pl \
243 ${libdir}/perl/${PV}/Config_heavy-target.pl"
244FILES_${PN}-pod = "${libdir}/perl/${PV}/pod \
245 ${libdir}/perl/${PV}/*.pod \
246 ${libdir}/perl/${PV}/*/*.pod \
247 ${libdir}/perl/${PV}/*/*/*.pod "
248FILES_perl-misc = "${bindir}/*"
249FILES_${PN}-dbg += "${libdir}/perl/${PV}/auto/*/.debug \
250 ${libdir}/perl/${PV}/auto/*/*/.debug \
251 ${libdir}/perl/${PV}/auto/*/*/*/.debug \
252 ${libdir}/perl/${PV}/CORE/.debug \
253 ${libdir}/perl/${PV}/*/.debug \
254 ${libdir}/perl/${PV}/*/*/.debug \
255 ${libdir}/perl/${PV}/*/*/*/.debug "
256FILES_${PN}-doc = "${libdir}/perl/${PV}/*/*.txt \
257 ${libdir}/perl/${PV}/*/*/*.txt \
258 ${libdir}/perl/${PV}/B/assemble \
259 ${libdir}/perl/${PV}/B/cc_harness \
260 ${libdir}/perl/${PV}/B/disassemble \
261 ${libdir}/perl/${PV}/B/makeliblinks \
262 ${libdir}/perl/${PV}/CGI/eg \
263 ${libdir}/perl/${PV}/CPAN/PAUSE2003.pub \
264 ${libdir}/perl/${PV}/CPAN/SIGNATURE \
265 ${libdir}/perl/${PV}/CPANPLUS/Shell/Default/Plugins/HOWTO.pod \
266 ${libdir}/perl/${PV}/Encode/encode.h \
267 ${libdir}/perl/${PV}/ExtUtils/MANIFEST.SKIP \
268 ${libdir}/perl/${PV}/ExtUtils/NOTES \
269 ${libdir}/perl/${PV}/ExtUtils/PATCHING \
270 ${libdir}/perl/${PV}/ExtUtils/typemap \
271 ${libdir}/perl/${PV}/ExtUtils/xsubpp \
272 ${libdir}/perl/${PV}/ExtUtils/Changes_EU-Install \
273 ${libdir}/perl/${PV}/Net/*.eg \
274 ${libdir}/perl/${PV}/unicore/mktables \
275 ${libdir}/perl/${PV}/unicore/mktables.lst \
276 ${libdir}/perl/${PV}/unicore/version "
277
278FILES_perl-module-cpan += "${libdir}/perl/${PV}/CPAN \
279 ${libdir}/perl/${PV}/CPAN.pm"
280FILES_perl-module-cpanplus += "${libdir}/perl/${PV}/CPANPLUS \
281 ${libdir}/perl/${PV}/CPANPLUS.pm"
282FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
283
284# Create a perl-modules package recommending all the other perl
285# packages (actually the non modules packages and not created too)
286ALLOW_EMPTY_perl-modules = "1"
287PACKAGES_append = " perl-modules "
288RRECOMMENDS_perl-modules = "${@bb.data.getVar('PACKAGES', d, 1).replace('${PN}-modules ', '').replace('${PN}-dbg ', '').replace('${PN}-misc ', '').replace('${PN}-dev ', '').replace('${PN}-pod ', '').replace('${PN}-doc ', '')}"
289
290python populate_packages_prepend () {
291 libdir = bb.data.expand('${libdir}/perl/${PV}', d)
292 do_split_packages(d, libdir, 'auto/(Encode/.[^/]*)/.*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
293 do_split_packages(d, libdir, 'auto/([^/]*)/.*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
294 do_split_packages(d, libdir, 'Module/([^\/]*).*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
295 do_split_packages(d, libdir, '(^(?!(CPAN\/|CPANPLUS\/|Module\/|unicore\/|auto\/)[^\/]).*)\.(pm|pl|e2x)', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
296}
297
298PACKAGES_DYNAMIC = "perl-module-*"
299
300RPROVIDES_perl-lib = "perl-lib"
301
302require perl-rdepends_${PV}.inc
303require perl-rprovides.inc
304require perl-rprovides_${PV}.inc