summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.14.2.bb
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-28 14:15:30 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-09-28 15:19:42 +0100
commit3d3893d26191307e99a261064885aeaf1e4c1ec7 (patch)
tree3b07687b2d42405aefda884a41a316f3bcb3f012 /meta/recipes-devtools/perl/perl_5.14.2.bb
parentc4788b733087d320a5b98edd485bff3195b185b4 (diff)
downloadpoky-3d3893d26191307e99a261064885aeaf1e4c1ec7.tar.gz
perl: Fix substitution madness
We're going around in circles trying to fix the sed expressions and making one case work and others not work. This patch fixes the base configuration file so we have non-overlapping substitutions. I've tried to significantly clean up various problems that were occurring once and for all. This will hopefully resolve all the issues people have been seeing with incorrect perl paths. (From OE-Core rev: 31ff70794ecc431431476f81c8934fff25383613) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index 00098553dd..09b2acb191 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -146,14 +146,14 @@ do_configure() {
146 ${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)} 146 ${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
147 147
148 # Update some paths in the configuration 148 # Update some paths in the configuration
149 sed -i -e 's,@DESTDIR@,${prefix},g' \ 149 sed -i -e 's,@ARCH@-thread-multi,,g' \
150 -e 's,@ARCH@-thread-multi,,g' \
151 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \ 150 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
152 -e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \ 151 -e 's,@STAGINGDIR@,${STAGING_DIR_HOST},g' \
153 -e "s%\([ \"^\',=]\+\)/usr/include\([ \"^\',=]\+\)%\1${STAGING_INCDIR}\2%g" \ 152 -e "s,@INCLUDEDIR@,${STAGING_INCDIR},g" \
154 -e "s%\([ \"^\',=]\+\)/usr/lib/\([ \"^\',=]\+\)%\1${libdir}/\2%g" \ 153 -e "s,@LIBDIR@,${libdir},g" \
155 -e "s%\([ \"^\',=]\+\)/usr/\([ \"^\',=]\+\)%\1${exec_prefix}/\2%g" \ 154 -e "s,@BASELIBDIR@,${base_libdir},g" \
156 -e "s%/perl5%/perl%g" \ 155 -e "s,@EXECPREFIX@,${exec_prefix},g" \
156 -e 's,@USRBIN@,${bindir},g' \
157 config.sh-${TARGET_ARCH}-${TARGET_OS} 157 config.sh-${TARGET_ARCH}-${TARGET_OS}
158 158
159 case "${TARGET_ARCH}" in 159 case "${TARGET_ARCH}" in