diff options
author | Kang Kai <kai.kang@windriver.com> | 2012-10-24 14:09:51 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-10-24 12:50:48 +0100 |
commit | f816625bf21348c1b0d887d11a77e7f5010ce76d (patch) | |
tree | 1d85871196d710c375ddc87b34815765bc4c0812 /meta/recipes-devtools/perl/perl_5.14.2.bb | |
parent | 645ba0309d1adf06de38d8123e5ba23b7d3270bb (diff) | |
download | poky-f816625bf21348c1b0d887d11a77e7f5010ce76d.tar.gz |
perl: update dependencies among modules
Run autoreconf fails because it uses several perl modules and they
requires other perl modules. So update these dependencies for:
perl-module-exporter
perl-module-file-glob
perl-module-file-path
perl-module-file-spec
perl-module-file-stat
perl-module-io-file
perl-module-io-handle
perl-module-io-seekable
perl-module-posix
And RDEPENDS rules in file perl-rdepends_5.14.2.inc don't work for
nativesdk perl module packages. Replace all "perl" with "${PN}" in the
file to fix that.
In nativesdk.bbclass it calls
oe.classextend.NativesdkClassExtender().map_packagevars() to map package
vars include var RDEPENDS. In map_packagevars():
for pkg in (self.d.getVar("PACKAGES", True).split() + [""]):
the value of var "PACKAGES" may not be calculated correctly, so for
all the nativesdk packages created by
PACKAGES_DYNAMIC_virtclass-nativesdk += "^nativesdk-perl-module-.*"
dependencies are wrong.
This is similar with 51cbb5ae76a22d465e2f6c5ef923ec2682624e3b.
Bump up PR.
(From OE-Core rev: c1f1368a680ae596e4d974a2cbbd253abc5118f8)
Signed-off-by: Kang Kai <kai.kang@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.14.2.bb')
-rw-r--r-- | meta/recipes-devtools/perl/perl_5.14.2.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb index 48ce156625..3ede8314d7 100644 --- a/meta/recipes-devtools/perl/perl_5.14.2.bb +++ b/meta/recipes-devtools/perl/perl_5.14.2.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \ | |||
7 | # We need gnugrep (for -I) | 7 | # We need gnugrep (for -I) |
8 | DEPENDS = "virtual/db grep-native" | 8 | DEPENDS = "virtual/db grep-native" |
9 | DEPENDS += "gdbm zlib" | 9 | DEPENDS += "gdbm zlib" |
10 | PR = "r12" | 10 | PR = "r13" |
11 | 11 | ||
12 | # 5.10.1 has Module::Build built-in | 12 | # 5.10.1 has Module::Build built-in |
13 | PROVIDES += "libmodule-build-perl" | 13 | PROVIDES += "libmodule-build-perl" |