summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl_5.12.3.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-10-19 14:53:17 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-24 17:27:14 +0100
commit5f8f114e4cc29e96942f96ef7dec6d25e18b6d4f (patch)
tree5b7867dec533d001ce29d8bf7b4869299cea254f /meta/recipes-devtools/perl/perl_5.12.3.bb
parent53f7342562a66d1b14ecee234aa76be07951dedc (diff)
downloadpoky-5f8f114e4cc29e96942f96ef7dec6d25e18b6d4f.tar.gz
perl: upgrade from 5.12.3 to 5.14.2
parallel build fix patches are not needed as they are upstream now. Got a new set of debian patch set for 5.14.2 perl-rpdepends: fix the autogenerated rdepends mistakes take out some mdoules which are not going to be built. [Saul Wold: Remove debug] (From OE-Core rev: 8dc5f118832a4aca906239ffed82f72497c37f8e) Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/perl_5.12.3.bb')
-rw-r--r--meta/recipes-devtools/perl/perl_5.12.3.bb309
1 files changed, 0 insertions, 309 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
deleted file mode 100644
index e4769a4235..0000000000
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ /dev/null
@@ -1,309 +0,0 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "devel"
4LICENSE = "Artistic|GPL"
5LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
6 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
7# We need gnugrep (for -I)
8DEPENDS = "virtual/db grep-native"
9DEPENDS += "gdbm zlib"
10PR = "r5"
11
12# 5.10.1 has Module::Build built-in
13PROVIDES += "libmodule-build-perl"
14
15# Major part of version
16#PVM = "5.13"
17
18SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
19 file://debian/arm_thread_stress_timeout.diff \
20 file://debian/cpan_config_path.diff \
21 file://debian/cpan_definstalldirs.diff \
22 file://debian/db_file_ver.diff \
23 file://debian/doc_info.diff \
24 file://debian/enc2xs_inc.diff \
25 file://debian/errno_ver.diff \
26 file://debian/extutils_hacks.diff \
27 file://debian/instmodsh_doc.diff \
28 file://debian/ld_run_path.diff \
29 file://debian/libnet_config_path.diff \
30 file://debian/m68k_thread_stress.diff \
31 file://debian/mod_paths.diff \
32 file://debian/module_build_man_extensions.diff \
33 file://debian/prune_libs.diff \
34 file://debian/fixes/net_smtp_docs.diff \
35 file://debian/fixes/processPL.diff \
36 file://debian/perlivp.diff \
37 file://debian/disable-zlib-bundling.diff \
38 file://debian/cpanplus_definstalldirs.diff \
39 file://debian/cpanplus_config_path.diff \
40 file://debian/fixes/autodie-flock.diff \
41 file://debian/devel-ppport-ia64-optim.diff \
42 file://debian/fixes/cpanplus-without-home.diff \
43 file://debian/arm_optim.diff \
44 file://debian/deprecate-with-apt.diff \
45 file://debian/fixes/hurd-ccflags.diff \
46 file://debian/squelch-locale-warnings.diff \
47 file://debian/fixes/lc-numeric-docs.diff \
48 file://debian/fixes/lc-numeric-sprintf.diff \
49 file://debian/fixes/concat-stack-corruption.diff \
50 file://debian/fixes/h2ph-gcc-4.5.diff \
51 file://debian/patchlevel \
52 \
53 file://Makefile.patch \
54 file://parallel_build_fix_1.patch \
55 file://parallel_build_fix_2.patch \
56 file://parallel_build_fix_3.patch \
57 file://parallel_build_fix_4.patch \
58 file://parallel_build_fix_5.patch \
59 file://parallel_build_fix_6.patch \
60 file://Makefile.SH.patch \
61 file://installperl.patch \
62 file://perl-dynloader.patch \
63 file://perl-moreconfig.patch \
64 file://letgcc-find-errno.patch \
65 file://generate-sh.patch \
66 file://09_fix_installperl.patch \
67 file://native-perlinc.patch \
68 file://perl-enable-gdbm.patch \
69 file://cross-generate_uudmap.patch \
70 file://fix_bad_rpath.patch \
71 \
72 file://config.sh \
73 file://config.sh-32 \
74 file://config.sh-32-le \
75 file://config.sh-32-be \
76 file://config.sh-64 \
77 file://config.sh-64-le \
78 file://config.sh-64-be"
79# file://debian/fakeroot.diff
80
81SRC_URI[md5sum] = "29975a69dce54e47fcd6331c085c6c99"
82SRC_URI[sha256sum] = "5678bfd5c2cd59253a26171bf3e681235433b00c730eea8a8046e1b225c11d2f"
83
84inherit perlnative siteinfo
85
86# Where to find the native perl
87HOSTPERL = "${STAGING_BINDIR_NATIVE}/perl-native/perl${PV}"
88
89# Where to find .so files - use the -native versions not those from the target build
90export PERLHOSTLIB = "${STAGING_LIBDIR_NATIVE}/perl-native/perl/${PV}/"
91
92# LDFLAGS for shared libraries
93export LDDLFLAGS = "${LDFLAGS} -shared"
94
95# We're almost Debian, aren't we?
96CFLAGS += "-DDEBIAN"
97
98do_nolargefile() {
99 sed -i -e "s,\(uselargefiles=\)'define',\1'undef',g" \
100 -e "s,\(d_readdir64_r=\)'define',\1'undef',g" \
101 -e "s,\(readdir64_r_proto=\)'\w+',\1'0',g" \
102 -e "/ccflags_uselargefiles/d" \
103 -e "s/-Duselargefiles//" \
104 -e "s/-D_FILE_OFFSET_BITS=64//" \
105 -e "s/-D_LARGEFILE_SOURCE//" \
106 ${S}/Cross/config.sh-${TARGET_ARCH}-${TARGET_OS}
107}
108
109do_configure() {
110 # Make hostperl in build directory be the native perl
111 ln -sf ${HOSTPERL} hostperl
112
113 # Do our work in the cross subdir
114 cd Cross
115
116 # Generate configuration
117 rm -f config.sh-${TARGET_ARCH}-${TARGET_OS}
118 for i in ${WORKDIR}/config.sh \
119 ${WORKDIR}/config.sh-${SITEINFO_BITS} \
120 ${WORKDIR}/config.sh-${SITEINFO_BITS}-${SITEINFO_ENDIANNESS}; do
121 cat $i >> config.sh-${TARGET_ARCH}-${TARGET_OS}
122 done
123
124 # Fixups for uclibc
125 if [ "${TARGET_OS}" = "linux-uclibc" -o "${TARGET_OS}" = "linux-uclibceabi" ]; then
126 sed -i -e "s,\(d_crypt_r=\)'define',\1'undef',g" \
127 -e "s,\(d_futimes=\)'define',\1'undef',g" \
128 -e "s,\(crypt_r_proto=\)'\w+',\1'0',g" \
129 -e "s,\(d_getnetbyname_r=\)'define',\1'undef',g" \
130 -e "s,\(getnetbyname_r_proto=\)'\w+',\1'0',g" \
131 -e "s,\(d_getnetbyaddr_r=\)'define',\1'undef',g" \
132 -e "s,\(getnetbyaddr_r_proto=\)'\w+',\1'0',g" \
133 -e "s,\(d_getnetent_r=\)'define',\1'undef',g" \
134 -e "s,\(getnetent_r_proto=\)'\w+',\1'0',g" \
135 -e "s,\(d_sockatmark=\)'define',\1'undef',g" \
136 -e "s,\(d_sockatmarkproto=\)'\w+',\1'0',g" \
137 -e "s,\(d_eaccess=\)'define',\1'undef',g" \
138 -e "s,\(d_stdio_ptr_lval=\)'define',\1'undef',g" \
139 -e "s,\(d_stdio_ptr_lval_sets_cnt=\)'define',\1'undef',g" \
140 -e "s,\(d_stdiobase=\)'define',\1'undef',g" \
141 -e "s,\(d_stdstdio=\)'define',\1'undef',g" \
142 -e "s,-fstack-protector,-fno-stack-protector,g" \
143 config.sh-${TARGET_ARCH}-${TARGET_OS}
144 fi
145
146 ${@base_contains('DISTRO_FEATURES', 'largefile', '', 'do_nolargefile', d)}
147
148 # Update some paths in the configuration
149 sed -i -e 's,@DESTDIR@,${prefix},g' \
150 -e 's,@ARCH@-thread-multi,,g' \
151 -e 's,@ARCH@,${TARGET_ARCH}-${TARGET_OS},g' \
152 -e "s%/usr/include%${STAGING_INCDIR}%g" \
153 -e 's,/usr/lib/,${libdir}/,g' \
154 -e 's,/usr/,${exec_prefix}/,g' \
155 -e 's,/perl5,/perl,g' \
156 config.sh-${TARGET_ARCH}-${TARGET_OS}
157
158 case "${TARGET_ARCH}" in
159 x86_64 | powerpc | s390)
160 sed -i -e "s,\(need_va_copy=\)'undef',\1'define',g" \
161 config.sh-${TARGET_ARCH}-${TARGET_OS}
162 ;;
163 arm)
164 sed -i -e "s,\(d_u32align=\)'undef',\1'define',g" \
165 config.sh-${TARGET_ARCH}-${TARGET_OS}
166 ;;
167 esac
168 # These are strewn all over the source tree
169 for foo in `grep -I -m1 \/usr\/include\/.*\\.h ${WORKDIR}/* -r | cut -f 1 -d ":"` ; do
170 echo Fixing: $foo
171 sed -e "s%/usr/include/%${STAGING_INCDIR}/%g" -i $foo
172 done
173
174 rm -f config
175 echo "ARCH = ${TARGET_ARCH}" > config
176 echo "OS = ${TARGET_OS}" >> config
177}
178
179do_compile() {
180 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
181 sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' cpan/Compress-Raw-Zlib/config.in
182 sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
183 sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
184
185 cd Cross
186 oe_runmake perl LD="${CCLD}"
187}
188
189do_install() {
190 oe_runmake install DESTDIR=${D}
191 # Add perl pointing at current version
192 ln -sf perl${PV} ${D}${bindir}/perl
193
194 ln -sf perl ${D}/${libdir}/perl5
195
196 # Remove unwanted file
197 rm -f ${D}/${libdir}/perl/${PV}/.packlist
198
199 # Fix up shared library
200 mv ${D}/${libdir}/perl/${PV}/CORE/libperl.so ${D}/${libdir}/libperl.so.${PV}
201 ln -sf libperl.so.${PV} ${D}/${libdir}/libperl.so.5
202
203 # target config, used by cpan.bbclass to extract version information
204 install config.sh ${D}${libdir}/perl
205
206 ln -s Config_heavy.pl ${D}${libdir}/perl/${PV}/Config_heavy-target.pl
207
208}
209
210PACKAGE_PREPROCESS_FUNCS += "perl_package_preprocess"
211
212perl_package_preprocess () {
213 # Fix up installed configuration
214 sed -i -e "s,${D},,g" \
215 -e "s,-isystem${STAGING_INCDIR} ,,g" \
216 -e "s,${STAGING_LIBDIR},${libdir},g" \
217 -e "s,${STAGING_BINDIR},${bindir},g" \
218 -e "s,${STAGING_INCDIR},${includedir},g" \
219 -e "s,${STAGING_BINDIR_NATIVE}/perl-native/,${bindir}/,g" \
220 -e "s,${STAGING_BINDIR_NATIVE}/,,g" \
221 ${PKGD}${bindir}/h2xs \
222 ${PKGD}${bindir}/h2ph \
223 ${PKGD}${bindir}/pod2html \
224 ${PKGD}${bindir}/pod2latex \
225 ${PKGD}${bindir}/pod2man \
226 ${PKGD}${bindir}/pod2text \
227 ${PKGD}${bindir}/pod2usage \
228 ${PKGD}${bindir}/podchecker \
229 ${PKGD}${bindir}/podselect \
230 ${PKGD}${libdir}/perl/${PV}/pod/*.pod \
231 ${PKGD}${libdir}/perl/${PV}/cacheout.pl \
232 ${PKGD}${libdir}/perl/${PV}/FileCache.pm \
233 ${PKGD}${libdir}/perl/config.sh \
234 ${PKGD}${libdir}/perl/${PV}/Config.pm \
235 ${PKGD}${libdir}/perl/${PV}/Config_heavy.pl \
236 ${PKGD}${libdir}/perl/${PV}/CORE/perl.h \
237 ${PKGD}${libdir}/perl/${PV}/CORE/pp.h
238}
239
240PACKAGES = "perl-dbg perl perl-misc perl-dev perl-pod perl-doc perl-lib \
241 perl-module-cpan perl-module-cpanplus perl-module-unicore"
242FILES_${PN} = "${bindir}/perl ${bindir}/perl${PV}"
243FILES_${PN}-dev = "${libdir}/perl/${PV}/CORE"
244FILES_${PN}-lib = "${libdir}/libperl.so* \
245 ${libdir}/perl5 \
246 ${libdir}/perl/config.sh \
247 ${libdir}/perl/${PV}/Config_heavy.pl \
248 ${libdir}/perl/${PV}/Config_heavy-target.pl"
249FILES_${PN}-pod = "${libdir}/perl/${PV}/pod \
250 ${libdir}/perl/${PV}/*.pod \
251 ${libdir}/perl/${PV}/*/*.pod \
252 ${libdir}/perl/${PV}/*/*/*.pod "
253FILES_perl-misc = "${bindir}/*"
254FILES_${PN}-dbg += "${libdir}/perl/${PV}/auto/*/.debug \
255 ${libdir}/perl/${PV}/auto/*/*/.debug \
256 ${libdir}/perl/${PV}/auto/*/*/*/.debug \
257 ${libdir}/perl/${PV}/CORE/.debug \
258 ${libdir}/perl/${PV}/*/.debug \
259 ${libdir}/perl/${PV}/*/*/.debug \
260 ${libdir}/perl/${PV}/*/*/*/.debug "
261FILES_${PN}-doc = "${libdir}/perl/${PV}/*/*.txt \
262 ${libdir}/perl/${PV}/*/*/*.txt \
263 ${libdir}/perl/${PV}/B/assemble \
264 ${libdir}/perl/${PV}/B/cc_harness \
265 ${libdir}/perl/${PV}/B/disassemble \
266 ${libdir}/perl/${PV}/B/makeliblinks \
267 ${libdir}/perl/${PV}/CGI/eg \
268 ${libdir}/perl/${PV}/CPAN/PAUSE2003.pub \
269 ${libdir}/perl/${PV}/CPAN/SIGNATURE \
270 ${libdir}/perl/${PV}/CPANPLUS/Shell/Default/Plugins/HOWTO.pod \
271 ${libdir}/perl/${PV}/Encode/encode.h \
272 ${libdir}/perl/${PV}/ExtUtils/MANIFEST.SKIP \
273 ${libdir}/perl/${PV}/ExtUtils/NOTES \
274 ${libdir}/perl/${PV}/ExtUtils/PATCHING \
275 ${libdir}/perl/${PV}/ExtUtils/typemap \
276 ${libdir}/perl/${PV}/ExtUtils/xsubpp \
277 ${libdir}/perl/${PV}/ExtUtils/Changes_EU-Install \
278 ${libdir}/perl/${PV}/Net/*.eg \
279 ${libdir}/perl/${PV}/unicore/mktables \
280 ${libdir}/perl/${PV}/unicore/mktables.lst \
281 ${libdir}/perl/${PV}/unicore/version "
282
283FILES_perl-module-cpan += "${libdir}/perl/${PV}/CPAN \
284 ${libdir}/perl/${PV}/CPAN.pm"
285FILES_perl-module-cpanplus += "${libdir}/perl/${PV}/CPANPLUS \
286 ${libdir}/perl/${PV}/CPANPLUS.pm"
287FILES_perl-module-unicore += "${libdir}/perl/${PV}/unicore"
288
289# Create a perl-modules package recommending all the other perl
290# packages (actually the non modules packages and not created too)
291ALLOW_EMPTY_perl-modules = "1"
292PACKAGES_append = " perl-modules "
293RRECOMMENDS_perl-modules = "${@bb.data.getVar('PACKAGES', d, 1).replace('${PN}-modules ', '').replace('${PN}-dbg ', '').replace('${PN}-misc ', '').replace('${PN}-dev ', '').replace('${PN}-pod ', '').replace('${PN}-doc ', '')}"
294
295python populate_packages_prepend () {
296 libdir = bb.data.expand('${libdir}/perl/${PV}', d)
297 do_split_packages(d, libdir, 'auto/(Encode/.[^/]*)/.*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
298 do_split_packages(d, libdir, 'auto/([^/]*)/.*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
299 do_split_packages(d, libdir, 'Module/([^\/]*).*', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
300 do_split_packages(d, libdir, '(^(?!(CPAN\/|CPANPLUS\/|Module\/|unicore\/|auto\/)[^\/]).*)\.(pm|pl|e2x)', 'perl-module-%s', 'perl module %s', recursive=True, allow_dirs=False, match_path=True, prepend=False)
301}
302
303PACKAGES_DYNAMIC = "perl-module-*"
304
305RPROVIDES_perl-lib = "perl-lib"
306
307require perl-rdepends_${PV}.inc
308require perl-rprovides.inc
309require perl-rprovides_${PV}.inc