summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.8.8.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-12-22 09:26:07 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-12 00:55:48 -0800
commitf57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d (patch)
treef6b24ea8f39fd6c83a161f91117641a851c4a9c6 /meta/recipes-devtools/perl/perl-native_5.8.8.bb
parentfde91acaf7849d80a2b9c908398bee2c3452004e (diff)
downloadpoky-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.gz
perl, perl-native: upgrade from 5.8.8 to 5.12.2
Deleted these patches as they are part of the upstream code now. deleted: files/perl-5.8.8-gcc-4.2.patch deleted: perl-5.12.2/makedepend-dash.patch deleted: perl-5.12.2/native-no-gdbminc.patch deleted: perl-5.12.2/54_debian_perldoc-r.patch And rebased these patches to the newer source code modified: files/letgcc-find-errno.patch modified: perl-5.12.2/Makefile.patch modified: perl-5.12.2/asm-pageh-fix.patch modified: perl-5.12.2/native-nopacklist.patch modified: perl-5.12.2/native-perlinc.patch modified: perl-5.12.2/Makefile.SH.patch modified: perl-5.12.2/installperl.patch modified: perl-5.12.2/perl-dynloader.patch modified: perl-5.12.2/09_fix_installperl.patch get patches from debian perl ver 5.12.2-2 the fakeroot.diff patch from debian is conflicting with our Makefile.SH.patch, hence disabling the fakeroot patch use newly created config files Created with current milestone branch on qemu machines modified: config.sh modified: config.sh-32 modified: config.sh-64 get some changes from oe's perl 5.10.1 recipe fix the Makefile.SH.patch use miniperl instead of perl import a OE 5.10.1 patch: uudmap_cross fix install issues add /usr in the destdir, so that perl gets installed in /usr/bin/perl and not in /bin/perl link /usr/lib/perl to /usr/lib/perl5 so that operations with /usr/lib/perl path in them keep on working. Fix/Improve perl packaging avoid perl-module-module-* kind of packages recreate perl-rdepends_5.12.2.inc file with new set of packages import from oe perl-rprovide_5.12.2.inc combine all unicore perl scripts in one package simplify perl-lib reduce no of perl recipe packages greatly. Add zlib to depedancy fix buildtime host contamination This also fixes [BUGID #384] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.8.8.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.8.8.bb104
1 files changed, 0 insertions, 104 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.8.8.bb b/meta/recipes-devtools/perl/perl-native_5.8.8.bb
deleted file mode 100644
index cc946af255..0000000000
--- a/meta/recipes-devtools/perl/perl-native_5.8.8.bb
+++ /dev/null
@@ -1,104 +0,0 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic|GPL"
5DEPENDS = "virtual/db-native gdbm-native"
6PR = "r14"
7
8LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
9 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
10
11SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
12 file://perl-5.8.8-gcc-4.2.patch;patch=1 \
13 file://Configure-multilib.patch;patch=1 \
14 file://perl-configpm-switch.patch;patch=1 \
15 file://native-nopacklist.patch;patch=1 \
16 file://native-no-gdbminc.patch;patch=1 \
17 file://native-perlinc.patch;patch=1 \
18 file://makedepend-dash.patch;patch=1 \
19 file://asm-pageh-fix.patch;patch=1"
20
21SRC_URI[md5sum] = "b8c118d4360846829beb30b02a6b91a7"
22SRC_URI[sha256sum] = "e15d499321e003d12ed183601e37ee7ba5f64b278d1de30149ce01bd4a3f234d"
23
24S = "${WORKDIR}/perl-${PV}"
25
26inherit native
27
28do_configure () {
29 ./Configure \
30 -Dcc="${CC}" \
31 -Dcflags="${CFLAGS}" \
32 -Dldflags="${LDFLAGS}" \
33 -Dcf_by="Open Embedded" \
34 -Dprefix=${prefix} \
35 -Dvendorprefix=${prefix} \
36 -Dvendorprefix=${prefix} \
37 -Dsiteprefix=${prefix} \
38 \
39 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
40 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
41 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
42 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
43 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
44 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
45 \
46 -Duseshrplib \
47 -Dusethreads \
48 -Duseithreads \
49 -Duselargefiles \
50 -Dnoextensions=ODBM_File \
51 -Ud_dosuid \
52 -Ui_db \
53 -Ui_ndbm \
54 -Ui_gdbm \
55 -Di_shadow \
56 -Di_syslog \
57 -Duseperlio \
58 -Dman3ext=3pm \
59 -Uafs \
60 -Ud_csh \
61 -Uusesfio \
62 -Uusenm -des
63}
64
65do_install () {
66 oe_runmake 'DESTDIR=${D}' install
67
68 # We need a hostperl link for building perl
69 ln -sf perl${PV} ${D}${bindir}/hostperl
70
71 install -d ${D}${libdir}/perl/${PV}/CORE \
72 ${D}${datadir}/perl/${PV}/ExtUtils
73
74 # Save native config
75 install config.sh ${D}${libdir}/perl
76 install lib/Config.pm ${D}${libdir}/perl/${PV}/
77 install lib/ExtUtils/typemap ${D}${datadir}/perl/${PV}/ExtUtils/
78
79 # perl shared library headers
80 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
81 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
82 perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
83 hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
84 cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
85 reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
86 nostdio.h perlapi.h perlvars.h reentr.inc thrdvar.h util.h \
87 dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
88 thread.h warnings.h; do
89 install $i ${D}${libdir}/perl/${PV}/CORE
90 done
91}
92do_install_append_nylon() {
93 # get rid of definitions not supported by the gcc version we use for nylon...
94 for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
95 perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
96 done
97}
98
99PARALLEL_MAKE = ""
100
101# Perl encodes the staging path into the perl binary so we have to depend on this
102# as part of the checksum for now
103HARDPATH := "${STAGING_BINDIR}"
104do_populate_sysroot[vardeps] += "HARDPATH"