summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/perl-native_5.12.2.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-12-22 09:26:07 -0800
committerSaul Wold <sgw@linux.intel.com>2011-01-12 00:55:48 -0800
commitf57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d (patch)
treef6b24ea8f39fd6c83a161f91117641a851c4a9c6 /meta/recipes-devtools/perl/perl-native_5.12.2.bb
parentfde91acaf7849d80a2b9c908398bee2c3452004e (diff)
downloadpoky-f57e9daf74d5fbab6c9a3f5e60e1320a0bf0642d.tar.gz
perl, perl-native: upgrade from 5.8.8 to 5.12.2
Deleted these patches as they are part of the upstream code now. deleted: files/perl-5.8.8-gcc-4.2.patch deleted: perl-5.12.2/makedepend-dash.patch deleted: perl-5.12.2/native-no-gdbminc.patch deleted: perl-5.12.2/54_debian_perldoc-r.patch And rebased these patches to the newer source code modified: files/letgcc-find-errno.patch modified: perl-5.12.2/Makefile.patch modified: perl-5.12.2/asm-pageh-fix.patch modified: perl-5.12.2/native-nopacklist.patch modified: perl-5.12.2/native-perlinc.patch modified: perl-5.12.2/Makefile.SH.patch modified: perl-5.12.2/installperl.patch modified: perl-5.12.2/perl-dynloader.patch modified: perl-5.12.2/09_fix_installperl.patch get patches from debian perl ver 5.12.2-2 the fakeroot.diff patch from debian is conflicting with our Makefile.SH.patch, hence disabling the fakeroot patch use newly created config files Created with current milestone branch on qemu machines modified: config.sh modified: config.sh-32 modified: config.sh-64 get some changes from oe's perl 5.10.1 recipe fix the Makefile.SH.patch use miniperl instead of perl import a OE 5.10.1 patch: uudmap_cross fix install issues add /usr in the destdir, so that perl gets installed in /usr/bin/perl and not in /bin/perl link /usr/lib/perl to /usr/lib/perl5 so that operations with /usr/lib/perl path in them keep on working. Fix/Improve perl packaging avoid perl-module-module-* kind of packages recreate perl-rdepends_5.12.2.inc file with new set of packages import from oe perl-rprovide_5.12.2.inc combine all unicore perl scripts in one package simplify perl-lib reduce no of perl recipe packages greatly. Add zlib to depedancy fix buildtime host contamination This also fixes [BUGID #384] Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-devtools/perl/perl-native_5.12.2.bb')
-rw-r--r--meta/recipes-devtools/perl/perl-native_5.12.2.bb104
1 files changed, 104 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl-native_5.12.2.bb b/meta/recipes-devtools/perl/perl-native_5.12.2.bb
new file mode 100644
index 0000000000..824d5076f8
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-native_5.12.2.bb
@@ -0,0 +1,104 @@
1DESCRIPTION = "Perl is a popular scripting language."
2HOMEPAGE = "http://www.perl.org/"
3SECTION = "libs"
4LICENSE = "Artistic|GPL"
5LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
6 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
7DEPENDS = "virtual/db-native gdbm-native"
8PR = "r0"
9
10LIC_FILES_CHKSUM = "file://Copying;md5=2b4c6ffbcfcbdee469f02565f253d81a \
11 file://Artistic;md5=f921793d03cc6d63ec4b15e9be8fd3f8"
12
13SRC_URI = "http://ftp.funet.fi/pub/CPAN/src/perl-${PV}.tar.gz \
14 file://Configure-multilib.patch;patch=1 \
15 file://perl-configpm-switch.patch;patch=1 \
16 file://native-nopacklist.patch;patch=1 \
17 file://native-perlinc.patch;patch=1"
18
19SRC_URI[md5sum] = "af2df531d46b77fdf0d97eecb03eddb2"
20SRC_URI[sha256sum] = "cf888340021d5a2d1238bbd9b8b55aaf420a848d46e4d317cb8567f86ceb1022"
21
22S = "${WORKDIR}/perl-${PV}"
23
24inherit native
25
26do_configure () {
27 ./Configure \
28 -Dcc="${CC}" \
29 -Dcflags="${CFLAGS}" \
30 -Dldflags="${LDFLAGS}" \
31 -Dcf_by="Open Embedded" \
32 -Dprefix=${prefix} \
33 -Dvendorprefix=${prefix} \
34 -Dvendorprefix=${prefix} \
35 -Dsiteprefix=${prefix} \
36 \
37 -Dprivlib=${STAGING_LIBDIR}/perl/${PV} \
38 -Darchlib=${STAGING_LIBDIR}/perl/${PV} \
39 -Dvendorlib=${STAGING_LIBDIR}/perl/${PV} \
40 -Dvendorarch=${STAGING_LIBDIR}/perl/${PV} \
41 -Dsitelib=${STAGING_LIBDIR}/perl/${PV} \
42 -Dsitearch=${STAGING_LIBDIR}/perl/${PV} \
43 \
44 -Duseshrplib \
45 -Dusethreads \
46 -Duseithreads \
47 -Duselargefiles \
48 -Dnoextensions=ODBM_File \
49 -Ud_dosuid \
50 -Ui_db \
51 -Ui_ndbm \
52 -Ui_gdbm \
53 -Di_shadow \
54 -Di_syslog \
55 -Duseperlio \
56 -Dman3ext=3pm \
57 -Uafs \
58 -Ud_csh \
59 -Uusesfio \
60 -Uusenm -des
61}
62
63do_install () {
64 oe_runmake 'DESTDIR=${D}' install
65
66 # We need a hostperl link for building perl
67 ln -sf perl${PV} ${D}${bindir}/hostperl
68
69 ln -sf perl ${D}${libdir}/perl5
70
71 install -d ${D}${libdir}/perl/${PV}/CORE \
72 ${D}${datadir}/perl/${PV}/ExtUtils
73
74 # Save native config
75 install config.sh ${D}${libdir}/perl
76 install lib/Config.pm ${D}${libdir}/perl/${PV}/
77 install lib/ExtUtils/typemap ${D}${libdir}/perl/${PV}/ExtUtils/
78
79 # perl shared library headers
80 for i in av.h embed.h gv.h keywords.h op.h perlio.h pp.h regexp.h \
81 uconfig.h XSUB.h cc_runtime.h embedvar.h handy.h opnames.h \
82 perliol.h pp_proto.h regnodes.h unixish.h config.h EXTERN.h \
83 hv.h malloc_ctl.h pad.h perlsdio.h proto.h scope.h utf8.h \
84 cop.h fakesdio.h INTERN.h mg.h patchlevel.h perlsfio.h \
85 reentr.h sv.h utfebcdic.h cv.h fakethr.h intrpvar.h \
86 nostdio.h perlapi.h perlvars.h util.h \
87 dosish.h form.h iperlsys.h opcode.h perl.h perly.h regcomp.h \
88 thread.h warnings.h; do
89 install $i ${D}${libdir}/perl/${PV}/CORE
90 done
91}
92do_install_append_nylon() {
93 # get rid of definitions not supported by the gcc version we use for nylon...
94 for i in ${D}${libdir}/perl/${PV}/Config_heavy.pl ${D}${libdir}/perl/config.sh; do
95 perl -pi -e 's/-Wdeclaration-after-statement //g' ${i}
96 done
97}
98
99PARALLEL_MAKE = ""
100
101# Perl encodes the staging path into the perl binary so we have to depend on this
102# as part of the checksum for now
103HARDPATH := "${STAGING_BINDIR}"
104do_populate_sysroot[vardeps] += "HARDPATH"