diff options
author | Jens Rehsack <sno@netbsd.org> | 2018-08-22 11:04:24 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-23 07:50:00 +0100 |
commit | 292471701b2590f2a0f45293f3fa81198a9ac3d9 (patch) | |
tree | c58b0a517e1617e43d8e9e21b3a3442ce1a78246 /meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb | |
parent | 454443647a6b161192a510f1b4a1d460b73f9781 (diff) | |
download | poky-292471701b2590f2a0f45293f3fa81198a9ac3d9.tar.gz |
libxml-parser-perl: fix "...contains bad RPATH"
The perl distribution "XML-Parser" relies for configuration
on the tooling of Devel::CheckLib - which is not aware of
sysroot locations nor of reasonable compiler/link definitions
from outside.
This causes
ERROR: libxml-parser-perl-2.44-r0 do_package_qa: QA Issue: package libxml-parser-perl contains bad RPATH ${BUILDDIR}/tmp/work/core2-64-poky-linux/libxml-parser-perl/2.44-r0/recipe-sysroot/usr/lib in file ${BUILDDIR}/tmp/work/core2-64-poky-linux/libxml-parser-perl/2.44-r0/packages-split/libxml-parser-perl/usr/lib/perl/vendor_perl/5.24.4/auto/XML/Parser/Expat/Expat.so
package libxml-parser-perl contains bad RPATH ${BUILDDIR}/tmp/work/core2-64-poky-linux/libxml-parser-perl/2.44-r0/recipe-sysroot/usr/lib in file ${BUILDDIR}/tmp/work/core2-64-poky-linux/libxml-parser-perl/2.44-r0/packages-split/libxml-parser-perl/usr/lib/perl/vendor_perl/5.24.4/auto/XML/Parser/Expat/Expat.so [rpaths]
ERROR: libxml-parser-perl-2.44-r0 do_package_qa: QA run found fatal errors. Please consider fixing them.
ERROR: libxml-parser-perl-2.44-r0 do_package_qa: Function failed: do_package_qa
It's strongly encouraged to the maintainer @toddr to rework the
toolchain for up to date environments.
[RP: Added fix for nativesdk RPATH issues too]
(From OE-Core rev: b103bb9426c0e5e3ef0fe0c34274ad3a06af8b6a)
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb')
-rw-r--r-- | meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb | 16 |
1 files changed, 15 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb index c5e0ae6769..194ed6ac48 100644 --- a/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb +++ b/meta/recipes-devtools/perl/libxml-parser-perl_2.44.bb | |||
@@ -18,8 +18,22 @@ inherit cpan ptest-perl | |||
18 | 18 | ||
19 | # fix up sub MakeMaker project as arguments don't get propagated though | 19 | # fix up sub MakeMaker project as arguments don't get propagated though |
20 | # see https://rt.cpan.org/Public/Bug/Display.html?id=28632 | 20 | # see https://rt.cpan.org/Public/Bug/Display.html?id=28632 |
21 | do_configure_append_class-target() { | ||
22 | sed -E \ | ||
23 | -e 's:-L${STAGING_LIBDIR}::g' -e 's:-I${STAGING_INCDIR}::g' \ | ||
24 | -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g' \ | ||
25 | -i Makefile Expat/Makefile | ||
26 | } | ||
27 | |||
28 | do_configure_append_class-nativesdk() { | ||
29 | sed -E \ | ||
30 | -e 's:LD_RUN_PATH ?= ?"?[^"]*"?::g' \ | ||
31 | -i Makefile Expat/Makefile | ||
32 | } | ||
33 | |||
21 | do_configure_append() { | 34 | do_configure_append() { |
22 | sed 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' -i Makefile Expat/Makefile | 35 | sed -e 's:--sysroot=.*\(\s\|$\):--sysroot=${STAGING_DIR_TARGET} :g' \ |
36 | -i Makefile Expat/Makefile | ||
23 | sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile | 37 | sed 's:^FULL_AR = .*:FULL_AR = ${AR}:g' -i Expat/Makefile |
24 | # make sure these two do not build in parallel | 38 | # make sure these two do not build in parallel |
25 | sed 's!^$(INST_DYNAMIC):!$(INST_DYNAMIC): $(BOOTSTRAP)!' -i Expat/Makefile | 39 | sed 's!^$(INST_DYNAMIC):!$(INST_DYNAMIC): $(BOOTSTRAP)!' -i Expat/Makefile |