summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.74.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-05-04 18:36:30 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-15 10:56:49 +0100
commit83a4c4b890a21b2dcafb0d2058982afc40a07369 (patch)
treef20eff1b5200e3d31f7d2b9760416831befcd4d8 /meta/recipes-devtools/perl/liburi-perl_1.74.bb
parent9e7be9f7349af50bc3cc00b0c2bb2507a3c85190 (diff)
downloadpoky-83a4c4b890a21b2dcafb0d2058982afc40a07369.tar.gz
liburi-perl: upgrade 1.73 -> 1.74
Upstream release notes: Changes for version 1.74 - 2018-04-22 avoid 'uninitialized' warning in URI::File when host has no domain name set (PR#53, thanks Shoichi Kaji!) (From OE-Core rev: 346afbee122a3e0642d552cd5b762e6f0b5a7957) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.74.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.74.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.74.bb b/meta/recipes-devtools/perl/liburi-perl_1.74.bb
new file mode 100644
index 0000000000..a7cfa0fbe3
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.74.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "892f7183b178af40f205ba37128225db"
17SRC_URI[sha256sum] = "a9c254f45f89cb1dd946b689dfe433095404532a4543bdaab0b71ce0fdcdd53d"
18
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan ptest-perl
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
30do_install_prepend() {
31 # these tests require "-T" (taint) command line option
32 rm -rf ${B}/t/cwd.t
33 rm -rf ${B}/t/file.t
34}
35
36RDEPENDS_${PN}-ptest += "libtest-needs-perl"
37
38BBCLASSEXTEND = "native"