summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.71.bb
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2016-12-06 11:33:31 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-12-08 10:31:30 +0000
commitac2913d7ed9fa4809eb6a27c3757eefcc82b7655 (patch)
treeead916bc8a259aa4b1546a5a2ad5ce61368b2604 /meta/recipes-devtools/perl/liburi-perl_1.71.bb
parent97b1bab2f729a1ffd09dda2fba225645ed6bd9ec (diff)
downloadpoky-ac2913d7ed9fa4809eb6a27c3757eefcc82b7655.tar.gz
liburi-perl: update to 1.71
Old version was broken by perl update. It was found by investigating configure errors in meta-qt5-extra/kf5: | [superandy@mueller-a-nb-linux 5.28.0-r0]$ /home/superandy/tmp/oe-core-glibc/sysroots/x86_64-linux/usr/bin/perl-native/perl -e "use URI::Escape" | \C no longer supported in regex; marked by <-- HERE in m/(\ <-- HERE C)/ at /home/superandy/tmp/oe-core-glibc/sysroots/x86_64-linux/usr/lib/perl-native/perl/vendor_perl/5.24.0/URI/Escape.pm line 205. | Compilation failed in require at -e line 1. | BEGIN failed--compilation aborted at -e line 1. (From OE-Core rev: 0c2afb0f38a23d4f1540887b125914c9dde16dae) Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.71.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.71.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.71.bb b/meta/recipes-devtools/perl/liburi-perl_1.71.bb
new file mode 100644
index 0000000000..a800198b33
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.71.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "247c3da29a794f72730e01aa5a715daf"
17SRC_URI[sha256sum] = "9c8eca0d7f39e74bbc14706293e653b699238eeb1a7690cc9c136fb8c2644115"
18
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
30BBCLASSEXTEND = "native"