summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.60.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2012-07-25 17:42:44 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-07-26 14:55:19 +0100
commiteefbd2e6a083d40fd5e2a113b2404548f92f5d81 (patch)
treeb0a32ee03c7c87b44a1a05c7be862863ad9a98b7 /meta/recipes-devtools/perl/liburi-perl_1.60.bb
parent5af0be987e1117fe830de72e646ef372a12f923f (diff)
downloadpoky-eefbd2e6a083d40fd5e2a113b2404548f92f5d81.tar.gz
liburi-perl: update to 1.60
Update to 1.60 (From OE-Core rev: 987c57c9a19706067f1590e0f647557a870f769c) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.60.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.60.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.60.bb b/meta/recipes-devtools/perl/liburi-perl_1.60.bb
new file mode 100644
index 0000000000..4eb98b21a2
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.60.bb
@@ -0,0 +1,27 @@
1DESCRIPTION = "This package contains the URI.pm module with friends. \
2The module implements the URI class. URI objects can be used to access \
3and manipulate the various components that make up these strings."
4
5SECTION = "libs"
6LICENSE = "Artistic-1.0 | GPL-1.0+"
7PR = "r0"
8
9LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
10
11DEPENDS += "perl"
12
13SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "70f739be8ce28b8baba7c5920ffee4dc"
16SRC_URI[sha256sum] = "1f92d3dc64acb8845e9917c945e22b9a5275aeb9ff924eb7873c3b7a5c0d2377"
17
18S = "${WORKDIR}/URI-${PV}"
19
20EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
21
22inherit cpan
23
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}