summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liburi-perl_1.59.bb
diff options
context:
space:
mode:
authorKang Kai <kai.kang@windriver.com>2011-10-18 16:42:32 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-10-20 17:13:40 +0100
commit0c864219a50867731ea526ff95b7d8144136ce39 (patch)
treeabf496a86de16b89cefa1e883739489d1e29da21 /meta/recipes-devtools/perl/liburi-perl_1.59.bb
parent2fb62c74fa2d535ef41a7e9b193530aae9c31f3d (diff)
downloadpoky-0c864219a50867731ea526ff95b7d8144136ce39.tar.gz
liburi-perl: update to 1.59
Update liburi-perl to 1.59 (From OE-Core rev: b3cbb5a8e8aeeb3a55649dba1aca73595305309e) Signed-off-by: Kang Kai <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liburi-perl_1.59.bb')
-rw-r--r--meta/recipes-devtools/perl/liburi-perl_1.59.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liburi-perl_1.59.bb b/meta/recipes-devtools/perl/liburi-perl_1.59.bb
new file mode 100644
index 0000000000..877b25212c
--- /dev/null
+++ b/meta/recipes-devtools/perl/liburi-perl_1.59.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "This package contains the URI.pm module with friends. \
2The module implements the URI class. URI objects can be used to access \
3and manipulate the various components that make up these strings."
4
5SECTION = "libs"
6LICENSE = "Artistic | GPLv1+"
7PR = "r0"
8
9LIC_FILES_CHKSUM = "file://README;beginline=26;endline=30;md5=6c33ae5c87fd1c4897714e122dd9c23d"
10
11DEPENDS += "perl"
12
13SRC_URI = "http://www.cpan.org/authors/id/G/GA/GAAS/URI-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "fecebf8fa20e2d26ea4a1649c095e96e"
16SRC_URI[sha256sum] = "cb88d29b589db8d2adbc4713fd082284cba77883488717375f011bbd13b5cac6"
17
18S = "${WORKDIR}/URI-${PV}"
19
20EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
21
22inherit cpan
23
24do_compile() {
25 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
26 cpan_do_compile
27}
28