summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-02-01 12:20:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-03 22:08:25 +0000
commit58fe3dab440c54f4893d7b151e468013285eb5fc (patch)
treed4efafeb1636201378deea8cb96072bb90dc456d /meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb
parent57777b3df5cd3a55b8319157e2e89329b2fb31f0 (diff)
downloadpoky-58fe3dab440c54f4893d7b151e468013285eb5fc.tar.gz
libtest-warnings-perl: upgrade 0.032 -> 0.033
Changelog: ============ - add Test2 compatibility in the test triggered by done_testing(); - new long-awaited feature (!!!) "allow_patterns", to either temporarily or globally exempt particular warning patterns (From OE-Core rev: ed3940f403ea4b9b2d875595953863dd28d94b8b) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb')
-rw-r--r--meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb b/meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb
new file mode 100644
index 0000000000..17b4cc3c9e
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-warnings-perl_0.033.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Test::Warnings - Test for warnings and the lack of them"
2DESCRIPTION = "If you've ever tried to use Test::NoWarnings to confirm there are no \
3warnings generated by your tests, combined with the convenience of \
4\\"done_testing\\" to not have to declare a test count, you'll have discovered \
5that these two features do not play well together, as the test count will \
6be calculated *before* the warnings test is run, resulting in a TAP error. \
7(See "examples/test_nowarnings.pl" in this distribution for a \
8demonstration.)"
9HOMEPAGE = "https://github.com/karenetheridge/Test-Warnings"
10BUGTRACKER = "https://rt.cpan.org/Public/Dist/Display.html?Name=Test-Warnings"
11SECTION = "libs"
12LICENSE = "Artistic-1.0-Perl | GPL-1.0-or-later"
13
14LIC_FILES_CHKSUM = "file://LICENCE;md5=f98106ac3cc05d9cbebcdb8fbf7b7815"
15
16SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETHER/Test-Warnings-${PV}.tar.gz"
17
18SRC_URI[sha256sum] = "b9c375719f2c61c5f97aa5ee6cf4c901a972347c415969379b0b51f67c48bbcb"
19
20S = "${WORKDIR}/Test-Warnings-${PV}"
21
22inherit cpan ptest-perl
23
24RDEPENDS:${PN} += "\
25 perl-module-test-builder \
26"
27
28# Many hidden dependencies and mysterious failures occur without full perl-modules
29RDEPENDS:${PN}-ptest += "perl-modules"
30
31do_install_ptest_perl:append () {
32 cp -r ${B}/t/lib ${D}${PTEST_PATH}/t/
33 chown -R root:root ${D}${PTEST_PATH}/t/lib
34}
35
36BBCLASSEXTEND = "native nativesdk"