summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2019-05-15 17:29:19 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 16:35:12 +0100
commit479c981d451ab735691e74965937ddf4e8fceffa (patch)
treeb45066f97ec0458b7314446fc24e6af25cb0ee62 /meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb
parent7a73a435e086df39b0a241250bed35c29e0e5a00 (diff)
downloadpoky-479c981d451ab735691e74965937ddf4e8fceffa.tar.gz
libtest-needs-perl: upgrade 0.002005 -> 0.002006
Change SRC_URI to https://cpan.metacpan.org License-Update: Lines moved further down in README. Upstream release notes: 0.002006 - 2019-04-04 - added additional references to related modules in pod - various internal cleanups - fix backwards compatibility with earlier versions of version.pm - fix output from test script when tests fail - added note about RELEASE_TESTING to test message on forced failures (From OE-Core rev: bec77f5d48055bd30ee69acb43d67c2d05180f7b) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb')
-rw-r--r--meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb b/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb
new file mode 100644
index 0000000000..3abb9aa8e4
--- /dev/null
+++ b/meta/recipes-devtools/perl/libtest-needs-perl_0.002006.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Skip tests when modules not available"
2DESCRIPTION = "Skip test scripts if modules are not available. \
3The requested modules will be loaded, and optionally have their versions \
4checked. If the module is missing, the test script will be skipped. Modules \
5that are found but fail to compile will exit with an error rather than skip."
6
7HOMEPAGE = "https://metacpan.org/release/Test-Needs"
8SECTION = "libs"
9LICENSE = "Artistic-1.0 | GPL-1.0+"
10
11CPAN_NAME = "Test-Needs"
12CPAN_AUTHOR = "HAARG"
13
14LIC_FILES_CHKSUM = "file://README;md5=3f3ccd21a0a48aa313db212cc3b1bc09;beginline=88;endline=89"
15
16DEPENDS += "perl"
17
18SRC_URI = "https://cpan.metacpan.org/authors/id/H/HA/${CPAN_AUTHOR}/${CPAN_NAME}-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "d5c96d51d8d5510f7c0b7f354c49af1c"
21SRC_URI[sha256sum] = "77f9fff0c96c5e09f34d0416b3533c3319f7cd0bb1f7fe8f8072ad59f433f0e5"
22
23S = "${WORKDIR}/${CPAN_NAME}-${PV}"
24
25inherit cpan ptest-perl
26
27RDEPENDS_${PN}-ptest += "perl-module-test-more"
28
29BBCLASSEXTEND = "native"