diff options
author | Tim Orling <tim.orling@konsulko.com> | 2024-03-28 09:22:21 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2024-03-30 22:22:19 +0000 |
commit | 863a7dd585cc898cd1e822f85f00cfc8307defc9 (patch) | |
tree | c61d7fb3454fdcce96a7abaf7637854e2df13208 /meta/recipes-devtools/perl/liberror-perl_0.17029.bb | |
parent | 854b0ee4bd80c29f9b63b5f5e70da01c3b20c6e2 (diff) | |
download | poky-863a7dd585cc898cd1e822f85f00cfc8307defc9.tar.gz |
liberror-perl: move to meta-perl
The upstream maintainer for Error has deprecated it for quite some time [1].
The only dependency in oe-core was coreutils-ptest.
[YOCTO #15461]
[1] https://metacpan.org/pod/Error#WARNING
Using the "Error" module is no longer recommended due to the black-magical
nature of its syntactic sugar, which often tends to break. Its maintainers
have stopped actively writing code that uses it, and discourage people from
doing so. See the "SEE ALSO" section below for better recommendations [2].
[2] https://metacpan.org/pod/Error#SEE-ALSO
SEE ALSO
--------
See Exception::Class for a different module providing Object-Oriented
exception handling, along with a convenient syntax for declaring hierarchies
for them. It doesn't provide Error's syntactic sugar of try { ... },
catch { ... }, etc. which may be a good thing or a bad thing based on what
you want. (Because Error's syntactic sugar tends to break.)
Error::Exception aims to combine Error and Exception::Class "with correct
stringification".
TryCatch and Try::Tiny are similar in concept to Error.pm only providing a
syntax that hopefully breaks less.
(From OE-Core rev: 7750469e0acfb7f7ef5b3002d1562df5354e6a61)
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liberror-perl_0.17029.bb')
-rw-r--r-- | meta/recipes-devtools/perl/liberror-perl_0.17029.bb | 48 |
1 files changed, 0 insertions, 48 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17029.bb b/meta/recipes-devtools/perl/liberror-perl_0.17029.bb deleted file mode 100644 index e54bb11ccd..0000000000 --- a/meta/recipes-devtools/perl/liberror-perl_0.17029.bb +++ /dev/null | |||
@@ -1,48 +0,0 @@ | |||
1 | SUMMARY = "Error - Error/exception handling in an OO-ish way" | ||
2 | DESCRIPTION = "The Error package provides two interfaces. Firstly \ | ||
3 | Error provides a procedural interface to exception handling. \ | ||
4 | Secondly Error is a base class for errors/exceptions that can \ | ||
5 | either be thrown, for subsequent catch, or can simply be recorded." | ||
6 | HOMEPAGE = "https://github.com/shlomif/perl-error.pm" | ||
7 | SECTION = "libs" | ||
8 | LICENSE = "Artistic-1.0 | GPL-1.0-or-later" | ||
9 | |||
10 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100" | ||
11 | |||
12 | |||
13 | DEPENDS += "perl" | ||
14 | |||
15 | RDEPENDS:${PN} += " \ | ||
16 | perl-module-carp \ | ||
17 | perl-module-exporter \ | ||
18 | perl-module-scalar-util \ | ||
19 | perl-module-overload \ | ||
20 | perl-module-strict \ | ||
21 | perl-module-vars \ | ||
22 | perl-module-warnings \ | ||
23 | " | ||
24 | |||
25 | RDEPENDS:${PN}-ptest += " \ | ||
26 | perl-module-base \ | ||
27 | perl-module-file-spec \ | ||
28 | perl-module-io-handle \ | ||
29 | perl-module-ipc-open3 \ | ||
30 | perl-module-lib \ | ||
31 | perl-module-test-more \ | ||
32 | " | ||
33 | |||
34 | SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz" | ||
35 | |||
36 | SRC_URI[md5sum] = "6732b1c6207e4a9a3e2987c88368039a" | ||
37 | SRC_URI[sha256sum] = "1a23f7913032aed6d4b68321373a3899ca66590f4727391a091ec19c95bf7adc" | ||
38 | |||
39 | S = "${WORKDIR}/Error-${PV}" | ||
40 | |||
41 | inherit cpan ptest-perl | ||
42 | |||
43 | do_install:prepend() { | ||
44 | # test requires "-T" (taint) command line option | ||
45 | rm -rf ${B}/t/pod-coverage.t | ||
46 | } | ||
47 | |||
48 | BBCLASSEXTEND = "native" | ||