summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/perl/liberror-perl_0.17027.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-12-09 13:43:22 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-12-13 16:32:21 +0000
commit2720226d827bba2f03cbfffdf4b2220621fce431 (patch)
tree43e94a590329ae3a84a874f330d4380944072439 /meta/recipes-devtools/perl/liberror-perl_0.17027.bb
parentd0c2395db30c1145dffa32b8d8a4a6ba48970302 (diff)
downloadpoky-2720226d827bba2f03cbfffdf4b2220621fce431.tar.gz
liberror-perl: upgrade 0.17026 -> 0.17027
* add RDEPENDS * add RDEPENDS for ptest - tested on qemux86 with glibc and musl * drop do_compile, not obvious why LIBC needed to be set * Added HOMEPAGE: https://bitbucket.org/shlomif/perl-error.pm - Repository used to be github.com/shlomif (deadlink) Upstream release notes: """ 0.17027 2018-10-28 - Documentation and examples enhancements. - https://bitbucket.org/shlomif/perl-error.pm/pull-requests/1/october-prc-some-minor-mostly-doc-changes/diff - Thanks to https://metacpan.org/author/JMERELO . """ (From OE-Core rev: 236e801df6e3bd859acc2b8456880a4bc4f0943c) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/perl/liberror-perl_0.17027.bb')
-rw-r--r--meta/recipes-devtools/perl/liberror-perl_0.17027.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/liberror-perl_0.17027.bb b/meta/recipes-devtools/perl/liberror-perl_0.17027.bb
new file mode 100644
index 0000000000..cf1f6d685f
--- /dev/null
+++ b/meta/recipes-devtools/perl/liberror-perl_0.17027.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Error - Error/exception handling in an OO-ish way"
2DESCRIPTION = "The Error package provides two interfaces. Firstly \
3Error provides a procedural interface to exception handling. \
4Secondly Error is a base class for errors/exceptions that can \
5either be thrown, for subsequent catch, or can simply be recorded."
6HOMEPAGE = "https://bitbucket.org/shlomif/perl-error.pm"
7SECTION = "libs"
8LICENSE = "Artistic-1.0 | GPL-1.0+"
9
10LIC_FILES_CHKSUM = "file://LICENSE;md5=8f3499d09ee74a050c0319391ff9d100"
11
12DEPENDS += "perl"
13
14RDEPENDS_${PN} += " \
15 perl-module-carp \
16 perl-module-exporter \
17 perl-module-scalar-util \
18 perl-module-overload \
19 perl-module-strict \
20 perl-module-vars \
21 perl-module-warnings \
22"
23
24RDEPENDS_${PN}-ptest += " \
25 perl-module-base \
26 perl-module-file-spec \
27 perl-module-io-handle \
28 perl-module-ipc-open3 \
29 perl-module-lib \
30 perl-module-test-more \
31"
32
33SRC_URI = "http://cpan.metacpan.org/authors/id/S/SH/SHLOMIF/Error-${PV}.tar.gz"
34
35SRC_URI[md5sum] = "4ef9b2890fb144d804527ba32573dd56"
36SRC_URI[sha256sum] = "07b2ac8275dfa04144745a6c1900a596280f862b97d22bab0c5ce02682ebd3be"
37
38S = "${WORKDIR}/Error-${PV}"
39
40inherit cpan ptest-perl
41
42do_install_prepend() {
43 # test requires "-T" (taint) command line option
44 rm -rf ${B}/t/pod-coverage.t
45}
46
47BBCLASSEXTEND = "native"