summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-02-06 03:48:09 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-02-15 20:06:42 -0800
commit0355491595e02c41d5ad5f4d16768d48a2d890af (patch)
treec962de4470376059f6a887aadb458d9530575307 /meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
parente051c702503614b45d68f4c4c10ed413b2ea5c66 (diff)
downloadpoky-0355491595e02c41d5ad5f4d16768d48a2d890af.tar.gz
pax-utils: 1.1.6 -> 1.2.2
Export GNULIB_OVERRIDES_WINT_T to fix compile failure --------- 1099 make[4]: *** [printf-args.o] Error 1 1100 make[4]: *** Waiting for unfinished jobs.... 1101 In file included from ../../../pax-utils-1.2.2/autotools/gnulib/printf-args.h:41:0, 1102 from ../../../pax-utils-1.2.2/autotools/gnulib/printf-parse.h:29, 1103 from ../../../pax-utils-1.2.2/autotools/gnulib/printf-parse.c:36: 1104 ./wchar.h:476:6: error: #if with no expression 1105 # if 1106 ^ 1107 make[4]: *** [printf-parse.o] Error 1 --------- (From OE-Core rev: 0f6f9fb0c898fe47e95803836f73a1850ad3bc6b) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb')
-rw-r--r--meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
new file mode 100644
index 0000000000..a032a22c22
--- /dev/null
+++ b/meta/recipes-devtools/pax-utils/pax-utils_1.2.2.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Security-focused ELF files checking tool"
2DESCRIPTION = "This is a small set of various PaX aware and related \
3utilities for ELF binaries. It can check ELF binary files and running \
4processes for issues that might be relevant when using ELF binaries \
5along with PaX, such as non-PIC code or executable stack and heap."
6HOMEPAGE = "http://www.gentoo.org/proj/en/hardened/pax-utils.xml"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
9
10SRC_URI = "http://gentoo.osuosl.org/distfiles/pax-utils-${PV}.tar.xz \
11"
12
13SRC_URI[md5sum] = "a580468318f0ff42edf4a8cd314cc942"
14SRC_URI[sha256sum] = "7f4a7f8db6b4743adde7582fa48992ad01776796fcde030683732f56221337d9"
15
16RDEPENDS_${PN} += "bash"
17
18export GNULIB_OVERRIDES_WINT_T = "0"
19
20do_configure_prepend() {
21 touch ${S}/NEWS ${S}/AUTHORS ${S}/ChangeLog ${S}/README
22}
23
24do_install() {
25 oe_runmake PREFIX=${D}${prefix} DESTDIR=${D} install
26}
27
28BBCLASSEXTEND = "native"
29
30inherit autotools pkgconfig
31
32PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
33"
34PACKAGECONFIG[libcap] = "--with-caps, --without-caps, libcap"
35PACKAGECONFIG[libseccomp] = "--with-seccomp, --without-seccomp, libseccomp"
36PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
37PACKAGECONFIG[pyelftools] = "--with-python, --without-python,, pyelftools"