summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/patchelf/patchelf_0.9.bb
diff options
context:
space:
mode:
authorFabio Berton <fabio.berton@ossystems.com.br>2016-09-14 09:30:29 -0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-15 12:15:07 +0100
commitd03439e0db02a0b6d165ca7da2d648add83d8649 (patch)
tree20e383a6698736bf9efa42c8e0084245d2751e74 /meta/recipes-devtools/patchelf/patchelf_0.9.bb
parenta6f0bced4c15f93a5e1c1b8782aa5dc6ca8d1113 (diff)
downloadpoky-d03439e0db02a0b6d165ca7da2d648add83d8649.tar.gz
patchelf: Update to version 0.9
* Remove patch maxsize.patch already applied upstream. * Add patch Skip-empty-section-fixes-66.patch to prevent errors like: / |ERROR: go-cross-1.6.2-r0 do_populate_sysroot_setscene: '('patchelf-uninative', |'--set-interpreter', '/home/user/src/prj/build/tmp/sysroots-uninative/ |x86_64-linux/lib/ld-linux-x86-64.so.2', '/home/user/src/prj/build/tmp/ |work/x86_64-linux/go-cross/1.6.2-r0/sstate-install-populate_sysroot/x86_64- |linux/usr/bin/aarch64-prj-linux/go')' |failed with exit code 1 and the following output: |cannot find section .rela.dyn \ * Add patch handle-read-only-files.patch to fix error when building eSKD, the following error appears on task do_testsdkext / |ERROR: db-native-6.0.30-r1 do_populate_sysroot_setscene: '('patchelf-uninative', |'--set-interpreter', 'src/fsl-community-bsp/build/tmp/work/qemuarm-poky-linux- |gnueabi/core-image-minimal/1.0-r0/testsdkext/tc/tmp/sysroots-uninative/ |x86_64-linux/lib/ld-linux-x86-64.so.2', 'src/fsl-community-bsp/build/tmp/work/ |qemuarm-poky-linux-gnueabi/core-image-minimal/1.0-r0/testsdkext/tc/tmp/work/ |x86_64-linux/db-native/6.0.30-r1/sstate-install-populate_sysroot/x86_64-linux/ |usr/bin/db_tuner')' failed with exit code 1 and the following output: |b'open: Permission denied\n \ * Add patch Increase-maxSize-to-64MB.patch to fix error described bellow, the same issue is discussed here: - https://github.com/NixOS/patchelf/issues/47 / |ERROR: qemu-native-2.5.0-r1 do_populate_sysroot_setscene: '('patchelf-uninative', |'--set-interpreter', '../build/tmp/sysroots-uninative/x86_64-linux/lib/ |ld-linux-x86-64.so.2', '../build/tmp/work/x86_64-linux/qemu-native/2.5.0-r1/ |sstate-install-populate_sysroot/x86_64-linux/usr/bin/qemu-mips64')' |failed with exit code 1 and the following output: |warning: working around a Linux kernel bug by creating a hole of 36032512 |bytes in ‘../build/tmp/work/x86_64-linux/qemu-native/2.5.0-r1/ |sstate-install-populate_sysroot/x86_64-linux/usr/bin/qemu-mips64’ |maximum file size exceeded \ (From OE-Core rev: 18efcbcb896239c64fedd009ce57f3f0c668cbc0) Signed-off-by: Fabio Berton <fabio.berton@ossystems.com.br> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/patchelf/patchelf_0.9.bb')
-rw-r--r--meta/recipes-devtools/patchelf/patchelf_0.9.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/patchelf/patchelf_0.9.bb b/meta/recipes-devtools/patchelf/patchelf_0.9.bb
new file mode 100644
index 0000000000..54e654bdcb
--- /dev/null
+++ b/meta/recipes-devtools/patchelf/patchelf_0.9.bb
@@ -0,0 +1,17 @@
1SRC_URI = "http://nixos.org/releases/${BPN}/${BPN}-${PV}/${BPN}-${PV}.tar.bz2 \
2 file://Skip-empty-section-fixes-66.patch \
3 file://handle-read-only-files.patch \
4 file://Increase-maxSize-to-64MB.patch \
5"
6
7LICENSE = "GPLv3"
8SUMMARY = "Tool to allow editing of RPATH and interpreter fields in ELF binaries"
9
10SRC_URI[md5sum] = "d02687629c7e1698a486a93a0d607947"
11SRC_URI[sha256sum] = "a0f65c1ba148890e9f2f7823f4bedf7ecad5417772f64f994004f59a39014f83"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
14
15inherit autotools
16
17BBCLASSEXTEND = "native nativesdk"