diff options
author | Mark Hatle <mark.hatle@windriver.com> | 2012-06-11 13:18:54 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-06-12 11:10:35 +0100 |
commit | b81d788c799a576dd1dc0db573639df69d91afef (patch) | |
tree | 3a96546c68c947b928fa24d4c52469d2b81133ec /meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb | |
parent | bc4a29df84542f0ef905a2e20d8533a0ea7cb613 (diff) | |
download | poky-b81d788c799a576dd1dc0db573639df69d91afef.tar.gz |
ossp-uuid: Add oss-uuid package and RPM 5.4.9 integration
RPM 5.4.9 now strongly encourages you to have the ossp-uuid library available.
Add this recipe, and change RPM to use the uuid functionality.
(From OE-Core rev: 8a2b55c5b7c544ec15113bc21e5c62276449c9c3)
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb')
-rw-r--r-- | meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb | 58 |
1 files changed, 58 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb new file mode 100644 index 0000000000..cc1ec75da1 --- /dev/null +++ b/meta/recipes-devtools/ossp-uuid/ossp-uuid_1.6.2.bb | |||
@@ -0,0 +1,58 @@ | |||
1 | SUMMARY = "Universally Unique Identifier (UUID) library" | ||
2 | DESCRIPTION = "OSSP uuid is a ISO-C:1999 application programming interface \ | ||
3 | (API) and corresponding command line interface (CLI) for the generation of \ | ||
4 | DCE 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique \ | ||
5 | Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1 (time \ | ||
6 | and node based), version 3 (name based, MD5), version 4 (random number \ | ||
7 | based) and version 5 (name based, SHA-1)." | ||
8 | DESCRIPTION_uuid = "This package contains a tool to create Universally \ | ||
9 | Unique Identifiers (UUID) from the command-line." | ||
10 | |||
11 | HOMEPAGE = "http://www.ossp.org/pkg/lib/uuid/" | ||
12 | SECTION = "libs" | ||
13 | |||
14 | LICENSE = "ossp_uuid" | ||
15 | LIC_FILES_CHKSUM = "file://README;beginline=30;endline=55;md5=b394fadb039bbfca6ad9d9d769ee960e" | ||
16 | |||
17 | PR = "r0" | ||
18 | |||
19 | SRC_URI = "ftp://ftp.ossp.org/pkg/lib/uuid/uuid-1.6.2.tar.gz \ | ||
20 | file://0001-Change-library-name.patch \ | ||
21 | file://0002-uuid-preserve-m-option-status-in-v-option-handling.patch \ | ||
22 | file://0003-Fix-whatis-entries.patch \ | ||
23 | file://0004-fix-data-uuid-from-string.patch \ | ||
24 | file://uuid-libtool.patch \ | ||
25 | file://uuid-nostrip.patch \ | ||
26 | " | ||
27 | SRC_URI[md5sum] = "5db0d43a9022a6ebbbc25337ae28942f" | ||
28 | SRC_URI[sha256sum] = "11a615225baa5f8bb686824423f50e4427acd3f70d394765bdff32801f0fd5b0" | ||
29 | |||
30 | S = "${WORKDIR}/uuid-${PV}" | ||
31 | |||
32 | inherit autotools | ||
33 | |||
34 | EXTRA_OECONF = "--without-dce --without-cxx --without-perl --without-perl-compat --without-php --without-pgsql" | ||
35 | EXTRA_OECONF = "--includedir=${includedir}/ossp" | ||
36 | |||
37 | do_configure_prepend() { | ||
38 | # This package has a completely custom aclocal.m4 | ||
39 | # so we need to back it up and make it usable... | ||
40 | if [ ! -e m4/ossp.m4 ]; then | ||
41 | mkdir m4 | ||
42 | mv aclocal.m4 m4/ossp.m4 | ||
43 | fi | ||
44 | |||
45 | rm -f libtool.m4 | ||
46 | } | ||
47 | |||
48 | do_install_append() { | ||
49 | mkdir -p ${D}${includedir}/ossp | ||
50 | mv ${D}${libdir}/pkgconfig/uuid.pc ${D}${libdir}/pkgconfig/ossp-uuid.pc | ||
51 | } | ||
52 | |||
53 | PACKAGES =+ "uuid" | ||
54 | FILES_uuid = "${bindir}/uuid" | ||
55 | FILES_${PN} = "${libdir}/libossp-uuid.so.16*" | ||
56 | FILES_${PN}-dev += "${bindir}/uuid-config" | ||
57 | |||
58 | BBCLASSEXTEND = "native" | ||