summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/orc/orc_0.4.26.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-10-23 14:29:51 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-11-06 23:35:34 +0000
commit3c17e96cc5dda7409bfec1aa5c9cc2010faf2111 (patch)
tree0b7b26da891c050862908ccd270ab6ef566d6c91 /meta/recipes-devtools/orc/orc_0.4.26.bb
parent659aeb76eb265b190d3efda15a3336971fd6e7b1 (diff)
downloadpoky-3c17e96cc5dda7409bfec1aa5c9cc2010faf2111.tar.gz
orc: Upgrade 0.4.25 -> 0.4.26
New upstream bugfix release (From OE-Core rev: 0918f605bff6407521f46058fedaaa9ee6bd1ebd) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/orc/orc_0.4.26.bb')
-rw-r--r--meta/recipes-devtools/orc/orc_0.4.26.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/orc/orc_0.4.26.bb b/meta/recipes-devtools/orc/orc_0.4.26.bb
new file mode 100644
index 0000000000..e47342f3fd
--- /dev/null
+++ b/meta/recipes-devtools/orc/orc_0.4.26.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Optimised Inner Loop Runtime Compiler"
2HOMEPAGE = "http://gstreamer.freedesktop.org/modules/orc.html"
3LICENSE = "BSD-2-Clause & BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1400bd9d09e8af56b9ec982b3d85797e"
5
6SRC_URI = "http://gstreamer.freedesktop.org/src/orc/orc-${PV}.tar.xz"
7
8SRC_URI[md5sum] = "8e9bef677bae289d3324d81c337a4507"
9SRC_URI[sha256sum] = "7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649"
10
11inherit autotools pkgconfig gtk-doc
12
13BBCLASSEXTEND = "native nativesdk"
14
15PACKAGES =+ "orc-examples"
16PACKAGES_DYNAMIC += "^liborc-.*"
17FILES_orc-examples = "${libdir}/orc/*"
18FILES_${PN} = "${bindir}/*"
19
20python populate_packages_prepend () {
21 libdir = d.expand('${libdir}')
22 do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
23}
24
25do_compile_prepend_class-native () {
26 sed -i -e 's#/tmp#.#g' ${S}/orc/orccodemem.c
27}