summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/orc/orc_0.4.25.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-05-04 11:20:21 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-11 10:33:39 +0100
commit64edecf8cd017c96201354586c038a4079570de7 (patch)
treee8e9a5dfb1a8ecf9a7a4ce146e6157eaefba32f6 /meta/recipes-devtools/orc/orc_0.4.25.bb
parent8d66086ac4dd8884a15168823fa1a02d5797fe96 (diff)
downloadpoky-64edecf8cd017c96201354586c038a4079570de7.tar.gz
orc: upgrade to 0.4.25
0.4.24 -> 0.4.25 (From OE-Core rev: c30f0484bedc7386339923a7851324eab2a59031) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/orc/orc_0.4.25.bb')
-rw-r--r--meta/recipes-devtools/orc/orc_0.4.25.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/orc/orc_0.4.25.bb b/meta/recipes-devtools/orc/orc_0.4.25.bb
new file mode 100644
index 0000000000..f3bde46f6b
--- /dev/null
+++ b/meta/recipes-devtools/orc/orc_0.4.25.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Optimised Inner Loop Runtime Compiler"
2HOMEPAGE = "http://gstreamer.freedesktop.org/modules/orc.html"
3LICENSE = "BSD-2-Clause & BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1400bd9d09e8af56b9ec982b3d85797e"
5
6SRC_URI = "http://gstreamer.freedesktop.org/src/orc/orc-${PV}.tar.xz"
7
8SRC_URI[md5sum] = "8582a28b15f53110c88d8043d9f55bcf"
9SRC_URI[sha256sum] = "c1b1d54a58f26d483f0b3881538984789fe5d5460ab8fab74a1cacbd3d1c53d1"
10
11inherit autotools pkgconfig
12
13BBCLASSEXTEND = "native nativesdk"
14
15PACKAGES =+ "orc-examples"
16PACKAGES_DYNAMIC += "^liborc-.*"
17FILES_orc-examples = "${libdir}/orc/*"
18FILES_${PN} = "${bindir}/*"
19
20python populate_packages_prepend () {
21 libdir = d.expand('${libdir}')
22 do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
23}
24
25do_compile_prepend_class-native () {
26 sed -i -e 's#/tmp#.#g' ${S}/orc/orccodemem.c
27}