diff options
author | Saul Wold <sgw@linux.intel.com> | 2012-01-20 11:05:16 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-01-24 11:54:20 +0000 |
commit | 930424bf2f5593256dcacac6e7cf98699fc2a0db (patch) | |
tree | 143397dca6c2a486335c5f1c24f0eb6821c873ef /meta/recipes-devtools/opkg/opkg_svn.bb | |
parent | c6c3f8745090c00eb02614a003925c533660e813 (diff) | |
download | poky-930424bf2f5593256dcacac6e7cf98699fc2a0db.tar.gz |
opkg: move common code & metadata into opkg.inc to reduce code duplication
(From OE-Core rev: da70cc9f33845d62943afc78168e56931d0a9b15)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_svn.bb')
-rw-r--r-- | meta/recipes-devtools/opkg/opkg_svn.bb | 42 |
1 files changed, 1 insertions, 41 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_svn.bb b/meta/recipes-devtools/opkg/opkg_svn.bb index f5f540d78e..c07d393019 100644 --- a/meta/recipes-devtools/opkg/opkg_svn.bb +++ b/meta/recipes-devtools/opkg/opkg_svn.bb | |||
@@ -1,14 +1,5 @@ | |||
1 | require opkg.inc | 1 | require opkg.inc |
2 | 2 | ||
3 | PROVIDES += "virtual/update-alternatives" | ||
4 | RPROVIDES_update-alternatives-cworth += "update-alternatives" | ||
5 | RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg" | ||
6 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base" | ||
7 | RDEPENDS_${PN}_virtclass-native = "" | ||
8 | RDEPENDS_${PN}_virtclass-nativesdk = "" | ||
9 | PACKAGE_ARCH_update-alternatives-cworth = "all" | ||
10 | RREPLACES_${PN} = "opkg-nogpg" | ||
11 | |||
12 | SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \ | 3 | SRC_URI = "svn://opkg.googlecode.com/svn;module=trunk;proto=http \ |
13 | file://add_vercmp.patch \ | 4 | file://add_vercmp.patch \ |
14 | file://add_uname_support.patch \ | 5 | file://add_uname_support.patch \ |
@@ -21,36 +12,5 @@ S = "${WORKDIR}/trunk" | |||
21 | 12 | ||
22 | SRCREV = "633" | 13 | SRCREV = "633" |
23 | PV = "0.1.8+svnr${SRCPV}" | 14 | PV = "0.1.8+svnr${SRCPV}" |
24 | PR = "r5" | ||
25 | |||
26 | PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}" | ||
27 | |||
28 | FILES_update-alternatives-cworth${PKGSUFFIX} = "${bindir}/update-alternatives" | ||
29 | FILES_libopkg${PKGSUFFIX}-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so" | ||
30 | FILES_libopkg${PKGSUFFIX} = "${libdir}/*.so.* ${localstatedir}/lib/opkg/" | ||
31 | |||
32 | # We need to create the lock directory | ||
33 | do_install_append() { | ||
34 | install -d ${D}${localstatedir}/lib/opkg | ||
35 | } | ||
36 | |||
37 | pkg_postinst_${PN} () { | ||
38 | #!/bin/sh | ||
39 | if [ "x$D" != "x" ]; then | ||
40 | install -d $D${sysconfdir}/rcS.d | ||
41 | # this happens at S98 where our good 'ole packages script used to run | ||
42 | echo "#!/bin/sh | ||
43 | opkg-cl configure | ||
44 | rm -f /${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure | ||
45 | " > $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure | ||
46 | chmod 0755 $D${sysconfdir}/rcS.d/S${POSTINSTALL_INITPOSITION}configure | ||
47 | fi | ||
48 | |||
49 | update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100 | ||
50 | } | ||
51 | |||
52 | pkg_postrm_${PN} () { | ||
53 | #!/bin/sh | ||
54 | update-alternatives --remove opkg ${bindir}/opkg-cl | ||
55 | } | ||
56 | 15 | ||
16 | PR = "${INC_PR}.0" | ||