summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.4.1.bb
diff options
context:
space:
mode:
authorAlejandro del Castillo <alejandro.delcastillo@ni.com>2019-06-24 14:27:06 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-27 12:20:36 +0100
commitf5379ec0d0942fff2f4c6a4ddceefc8a4fb2107d (patch)
tree1a48b0ca58f9b5e9036ee2e421c79768897ef911 /meta/recipes-devtools/opkg/opkg_0.4.1.bb
parente58f930df5a22ee42c27cff0ca12bc9bf961b74b (diff)
downloadpoky-f5379ec0d0942fff2f4c6a4ddceefc8a4fb2107d.tar.gz
opkg: upgrade to version 0.4.1
- Drop 0001-libopkg-add-add-ignore-recommends-option.patch - Drop 0001-opkg-add-target-for-testsuite-installation.patch - Drop 0001-regress-issue72.py-resolve-paths-before-comparision.patch - Remove test binaries tests\libopkg_test, leftovers from make dist process (From OE-Core rev: b14c17e9b1992a7f6c9acfa9ee82037325163b31) Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.4.1.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.4.1.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.4.1.bb b/meta/recipes-devtools/opkg/opkg_0.4.1.bb
new file mode 100644
index 0000000000..8c48d3097c
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg_0.4.1.bb
@@ -0,0 +1,76 @@
1SUMMARY = "Open Package Manager"
2SUMMARY_libopkg = "Open Package Manager library"
3SECTION = "base"
4HOMEPAGE = "http://code.google.com/p/opkg/"
5BUGTRACKER = "http://code.google.com/p/opkg/issues/list"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
8 file://src/opkg.c;beginline=2;endline=21;md5=90435a519c6ea69ef22e4a88bcc52fa0"
9
10DEPENDS = "libarchive"
11
12PE = "1"
13
14SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \
15 file://opkg.conf \
16 file://0001-opkg_conf-create-opkg.lock-in-run-instead-of-var-run.patch \
17 file://run-ptest \
18"
19
20SRC_URI[md5sum] = "ba0c21305fc93b26e844981ef100dc85"
21SRC_URI[sha256sum] = "45ac1e037d3877f635d883f8a555e172883a25d3eeb7986c75890fdd31250a43"
22
23# This needs to be before ptest inherit, otherwise all ptest files end packaged
24# in libopkg package if OPKGLIBDIR == libdir, because default
25# PTEST_PATH ?= "${libdir}/${BPN}/ptest"
26PACKAGES =+ "libopkg"
27
28inherit autotools pkgconfig systemd ptest
29
30target_localstatedir := "${localstatedir}"
31OPKGLIBDIR = "${target_localstatedir}/lib"
32
33PACKAGECONFIG ??= "libsolv"
34
35PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg"
36PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl"
37PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl"
38PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
39PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256"
40PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder"
41PACKAGECONFIG[libsolv] = "--with-libsolv,--without-libsolv,libsolv"
42
43EXTRA_OECONF_class-native = "--localstatedir=/${@os.path.relpath('${localstatedir}', '${STAGING_DIR_NATIVE}')} --sysconfdir=/${@os.path.relpath('${sysconfdir}', '${STAGING_DIR_NATIVE}')}"
44
45# Release tarball has unused binaries on the tests folder, automatically created by automake.
46# For now, delete them to avoid packaging errors (wrong architecture)
47do_unpack_append () {
48 bb.build.exec_func('remove_test_binaries', d)
49}
50
51remove_test_binaries () {
52 rm ${WORKDIR}/opkg-${PV}/tests/libopkg_test*
53}
54
55do_install_append () {
56 install -d ${D}${sysconfdir}/opkg
57 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
58 echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf
59
60 # We need to create the lock directory
61 install -d ${D}${OPKGLIBDIR}/opkg
62}
63
64RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config libarchive"
65RDEPENDS_${PN}_class-native = ""
66RDEPENDS_${PN}_class-nativesdk = ""
67RDEPENDS_${PN}-ptest += "make binutils python3-core python3-compression"
68RREPLACES_${PN} = "opkg-nogpg opkg-collateral"
69RCONFLICTS_${PN} = "opkg-collateral"
70RPROVIDES_${PN} = "opkg-collateral"
71
72FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/"
73
74BBCLASSEXTEND = "native nativesdk"
75
76CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"