diff options
author | Alejandro del Castillo <alejandro.delcastillo@ni.com> | 2015-09-01 09:17:53 -0500 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-09-03 12:43:14 +0100 |
commit | d6b1171131656907d6bdbb9ce3115c444f06817e (patch) | |
tree | d9764b40ac128da99f79c2e45cfd7c370f5179e2 /meta/recipes-devtools/opkg/opkg_0.2.4.bb | |
parent | ab50b1d11c28394b20b49242cc3481582a055bc8 (diff) | |
download | poky-d6b1171131656907d6bdbb9ce3115c444f06817e.tar.gz |
opkg: upgrade to v0.3.0
Changes required:
- Rename opkg-cl to opkg
- Add libarchive dependency
- Drop backport patches
- Drop obsolete directory options
- Add patch to handle empty index files
Based on initial work by Paul Barker.
(From OE-Core rev: 1dd2a9ea54f5a5497e23814f144f35ff15430d71)
Signed-off-by: Alejandro del Castillo <alejandro.delcastillo@ni.com>
CC: Paul Barker <paul@paulbarker.me.uk>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.2.4.bb')
-rw-r--r-- | meta/recipes-devtools/opkg/opkg_0.2.4.bb | 84 |
1 files changed, 0 insertions, 84 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.2.4.bb b/meta/recipes-devtools/opkg/opkg_0.2.4.bb deleted file mode 100644 index b7574e538e..0000000000 --- a/meta/recipes-devtools/opkg/opkg_0.2.4.bb +++ /dev/null | |||
@@ -1,84 +0,0 @@ | |||
1 | SUMMARY = "Open Package Manager" | ||
2 | SUMMARY_libopkg = "Open Package Manager library" | ||
3 | SECTION = "base" | ||
4 | HOMEPAGE = "http://code.google.com/p/opkg/" | ||
5 | BUGTRACKER = "http://code.google.com/p/opkg/issues/list" | ||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
8 | file://src/opkg-cl.c;beginline=1;endline=20;md5=321f658c3f6b6c832e25c8850b5dffba" | ||
9 | |||
10 | PE = "1" | ||
11 | |||
12 | SRC_URI = "http://downloads.yoctoproject.org/releases/${BPN}/${BPN}-${PV}.tar.gz \ | ||
13 | file://no-install-recommends.patch \ | ||
14 | file://add-exclude.patch \ | ||
15 | file://remove-ACLOCAL_AMFLAGS-I-shave-I-m4.patch \ | ||
16 | file://opkg-configure.service \ | ||
17 | file://opkg.conf \ | ||
18 | file://0001-opkg-key-Backport-improvements.patch \ | ||
19 | " | ||
20 | |||
21 | SRC_URI[md5sum] = "40ed2aee15abc8d550539449630091bd" | ||
22 | SRC_URI[sha256sum] = "0f40c7e457d81edf9aedc07c778f4697111ab163a38ef95999faece015453086" | ||
23 | |||
24 | inherit autotools pkgconfig systemd | ||
25 | |||
26 | SYSTEMD_SERVICE_${PN} = "opkg-configure.service" | ||
27 | |||
28 | target_localstatedir := "${localstatedir}" | ||
29 | OPKGLIBDIR = "${target_localstatedir}/lib" | ||
30 | |||
31 | PACKAGECONFIG ??= "" | ||
32 | |||
33 | PACKAGECONFIG[gpg] = "--enable-gpg,--disable-gpg,gpgme libgpg-error,gnupg" | ||
34 | PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl" | ||
35 | PACKAGECONFIG[ssl-curl] = "--enable-ssl-curl,--disable-ssl-curl,curl openssl" | ||
36 | PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl" | ||
37 | PACKAGECONFIG[sha256] = "--enable-sha256,--disable-sha256" | ||
38 | PACKAGECONFIG[pathfinder] = "--enable-pathfinder,--disable-pathfinder,pathfinder" | ||
39 | |||
40 | EXTRA_OECONF = "\ | ||
41 | --with-opkgetcdir=${sysconfdir} \ | ||
42 | --with-opkglibdir=${OPKGLIBDIR} \ | ||
43 | " | ||
44 | |||
45 | do_install_append () { | ||
46 | install -d ${D}${sysconfdir}/opkg | ||
47 | install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf | ||
48 | echo "option lists_dir ${OPKGLIBDIR}/opkg/lists" >>${D}${sysconfdir}/opkg/opkg.conf | ||
49 | |||
50 | # We need to create the lock directory | ||
51 | install -d ${D}${OPKGLIBDIR}/opkg | ||
52 | |||
53 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)};then | ||
54 | install -d ${D}${systemd_unitdir}/system | ||
55 | install -m 0644 ${WORKDIR}/opkg-configure.service ${D}${systemd_unitdir}/system/ | ||
56 | sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
57 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | ||
58 | -e 's,@BINDIR@,${bindir},g' \ | ||
59 | -e 's,@SYSTEMD_UNITDIR@,${systemd_unitdir},g' \ | ||
60 | ${D}${systemd_unitdir}/system/opkg-configure.service | ||
61 | fi | ||
62 | |||
63 | # The installed binary is 'opkg-cl' but people and scripts often expect | ||
64 | # it to just be 'opkg' | ||
65 | ln -sf opkg-cl ${D}${bindir}/opkg | ||
66 | |||
67 | rm ${D}${bindir}/update-alternatives | ||
68 | } | ||
69 | |||
70 | RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-arch-config run-postinsts" | ||
71 | RDEPENDS_${PN}_class-native = "" | ||
72 | RDEPENDS_${PN}_class-nativesdk = "" | ||
73 | RREPLACES_${PN} = "opkg-nogpg opkg-collateral" | ||
74 | RCONFLICTS_${PN} = "opkg-collateral" | ||
75 | RPROVIDES_${PN} = "opkg-collateral" | ||
76 | |||
77 | PACKAGES =+ "libopkg" | ||
78 | |||
79 | FILES_libopkg = "${libdir}/*.so.* ${OPKGLIBDIR}/opkg/" | ||
80 | FILES_${PN} += "${systemd_unitdir}/system/" | ||
81 | |||
82 | BBCLASSEXTEND = "native nativesdk" | ||
83 | |||
84 | CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf" | ||