diff options
author | Khem Raj <raj.khem@gmail.com> | 2016-12-21 09:34:12 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2017-01-09 13:39:12 +0000 |
commit | aaaa25022b8694949a95cc15d9cdbcb80e11291c (patch) | |
tree | 63415135acc8df6d1c9b950a82a6509e7083665a /meta/recipes-devtools/opkg-utils/opkg-utils_git.bb | |
parent | a17171ad666e10c4ec7897eac6913d43c54c76bf (diff) | |
download | poky-aaaa25022b8694949a95cc15d9cdbcb80e11291c.tar.gz |
opkg-utils: Do not use --ignore-fail-on-non-empty with rmdir
--ignore-fail-on-non-empty is coreutils specific, and you
are not always going to have coreutils on target systems
especially small ones. They will use the busybox applet which
does not support --ignore-fail-on-non-empty, use pipe and true
to ignore the errorcode from rmdir instead
Fixes upgrade errors on target e.g.
rmdir: unrecognized option '--ignore-fail-on-non-empty'
BusyBox v1.24.1 (2016-12-20 10:41:39 PST) multi-call binary.
Usage: rmdir [OPTIONS] DIRECTORY...
To remove package debris, try `opkg remove update-alternatives-opkg`.
To re-attempt the install, try `opkg install update-alternatives-opkg`.
Collected errors:
* pkg_run_script: package "update-alternatives-opkg" postrm script returned status 1.
* postrm_upgrade_old_pkg: postrm script for package "update-alternatives-opkg" failed
(From OE-Core rev: 5ec8934a495e9b9a782889bc3a84936c8a381165)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_git.bb')
-rw-r--r-- | meta/recipes-devtools/opkg-utils/opkg-utils_git.bb | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb index 7b01bfc346..4f90bcd13a 100644 --- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb +++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb | |||
@@ -46,7 +46,7 @@ RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" | |||
46 | 46 | ||
47 | pkg_postrm_update-alternatives-opkg() { | 47 | pkg_postrm_update-alternatives-opkg() { |
48 | rm -rf $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg/alternatives | 48 | rm -rf $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg/alternatives |
49 | rmdir --ignore-fail-on-non-empty $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg | 49 | rmdir $OPKG_OFFLINE_ROOT${nonarch_libdir}/opkg || true |
50 | } | 50 | } |
51 | 51 | ||
52 | BBCLASSEXTEND = "native nativesdk" | 52 | BBCLASSEXTEND = "native nativesdk" |