summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb
diff options
context:
space:
mode:
authorAlex Stewart <alex.stewart@ni.com>2021-06-09 16:10:42 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-06-11 23:50:58 +0100
commit2104ab479b19000d3e4e9ebbc61d112f9b8017ea (patch)
tree4fbde2f0c3fb685aa5c41d67bc0b182e5173c7b8 /meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb
parent39a6abee37c96281ab9b391c4b8afafadb761f7a (diff)
downloadpoky-2104ab479b19000d3e4e9ebbc61d112f9b8017ea.tar.gz
opkg-utils: upgrade to version 0.4.5
(From OE-Core rev: c1ac3d1a8af6d5752c8c1aa9d133ee35c18c743b) Signed-off-by: Alex Stewart <alex.stewart@ni.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb66
1 files changed, 0 insertions, 66 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb
deleted file mode 100644
index ce299d6b63..0000000000
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.3.bb
+++ /dev/null
@@ -1,66 +0,0 @@
1SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11 file://0001-update-alternatives-correctly-match-priority.patch \
12 "
13UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
14
15SRC_URI[md5sum] = "7bbadb3c381f3ea935b21d3bb8cc4671"
16SRC_URI[sha256sum] = "046517600fb0aed6c4645edefe02281f4fa2f1c02f71596152d93172452c0b01"
17
18TARGET_CC_ARCH += "${LDFLAGS}"
19
20RDEPENDS_${PN} += "bash"
21
22inherit perlnative
23
24# For native builds we use the host Python
25PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
26PYTHONRDEPS_class-native = ""
27
28PACKAGECONFIG = "python update-alternatives"
29PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
30PACKAGECONFIG[update-alternatives] = ",,,"
31
32do_install() {
33 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
34 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
35 rm -f "${D}${bindir}/update-alternatives"
36 fi
37}
38
39do_install_append_class-target() {
40 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
41 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
42 fi
43
44 if [ -e "${D}${bindir}/update-alternatives" ]; then
45 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
46 fi
47}
48
49# These are empty and will pull python3-dev into images where it wouldn't
50# have been otherwise, so don't generate them.
51PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
52
53PACKAGES =+ "update-alternatives-opkg"
54FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
55RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
56RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
57RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
58
59pkg_postrm_update-alternatives-opkg() {
60 rm -rf $D${nonarch_libdir}/opkg/alternatives
61 rmdir $D${nonarch_libdir}/opkg || true
62}
63
64BBCLASSEXTEND = "native nativesdk"
65
66CLEANBROKEN = "1"