diff options
author | Scott Garman <scott.a.garman@intel.com> | 2012-05-07 15:49:14 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-05-08 14:49:15 +0100 |
commit | cc9b58e7a7886eddd7fdd873941ff06c22a19bc0 (patch) | |
tree | feb439e5b43442587d64271a7794fb677440dd5e /meta/recipes-devtools/opensp/opensp_1.5.2.bb | |
parent | e11c4958865455a31cd255d6f1aab60abb84da59 (diff) | |
download | poky-cc9b58e7a7886eddd7fdd873941ff06c22a19bc0.tar.gz |
opensp: upgrade to 1.5.2
Removed all patches, they've been integrated upstream. :)
Added --disable-doc-build to prevent creation of docs, which
otherwise fails with the following configure error:
could not find xmlto; set XMLTO or consider --disable-doc-build
Removed configure_prepend step that was deleting the m4/ directory,
since some macros needed for the build are defined there, and I've
not encountered any problems with keeping them there in my testing.
(From OE-Core rev: cbd055917b04bf8fc640eee289e443230de139a2)
Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/opensp/opensp_1.5.2.bb')
-rw-r--r-- | meta/recipes-devtools/opensp/opensp_1.5.2.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opensp/opensp_1.5.2.bb b/meta/recipes-devtools/opensp/opensp_1.5.2.bb new file mode 100644 index 0000000000..ecf8a3738b --- /dev/null +++ b/meta/recipes-devtools/opensp/opensp_1.5.2.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | SUMMARY = "An SGML parser" | ||
2 | DESCRIPTION = "An SGML parser used by the OpenJade suite of utilities." | ||
3 | HOMEPAGE = "http://openjade.sourceforge.net" | ||
4 | SECTION = "libs" | ||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045" | ||
7 | |||
8 | PR = "r0" | ||
9 | |||
10 | # At -Os it encounters calls to some inline functions which are then | ||
11 | # not found in any other objects with gcc 4.5 | ||
12 | FULL_OPTIMIZATION += "-O2" | ||
13 | |||
14 | SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz" | ||
15 | |||
16 | SRC_URI[md5sum] = "670b223c5d12cee40c9137be86b6c39b" | ||
17 | SRC_URI[sha256sum] = "57f4898498a368918b0d49c826aa434bb5b703d2c3b169beb348016ab25617ce" | ||
18 | |||
19 | S = "${WORKDIR}/OpenSP-${PV}" | ||
20 | |||
21 | inherit autotools gettext | ||
22 | |||
23 | EXTRA_OECONF = "--disable-doc-build" | ||
24 | |||
25 | EXTRA_OECONF_virtclass-native = "\ | ||
26 | --disable-doc-build \ | ||
27 | --enable-default-catalog=${sysconfdir}/sgml/catalog \ | ||
28 | --enable-default-search-path=${datadir}/sgml \ | ||
29 | " | ||
30 | |||
31 | do_install_append() { | ||
32 | # Set up symlinks to often-used alternate names. See | ||
33 | # http://www.linuxfromscratch.org/blfs/view/stable/pst/opensp.html | ||
34 | cd ${D}${libdir} | ||
35 | ln -sf libosp.so libsp.so | ||
36 | |||
37 | cd ${D}${bindir} | ||
38 | for util in nsgmls sgmlnorm spam spcat spent sx; do | ||
39 | ln -sf o$util $util | ||
40 | done | ||
41 | ln -sf osx sgml2xml | ||
42 | } | ||
43 | |||
44 | do_install_append_virtclass-native() { | ||
45 | for util in nsgmls sgmlnorm spam spcat spent sx; do | ||
46 | create_cmdline_wrapper ${D}/${bindir}/$util \ | ||
47 | -D ${sysconfdir}/sgml | ||
48 | done | ||
49 | } | ||
50 | |||
51 | FILES_${PN} += "${datadir}/OpenSP/" | ||
52 | |||
53 | BBCLASSEXTEND = "native" | ||