diff options
author | Christopher Larson <chris_larson@mentor.com> | 2015-11-10 13:49:15 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-11-25 08:08:16 +0000 |
commit | 2ec77de50584b8c4863a1da66a2393bf64acd88e (patch) | |
tree | 0c21bdb0f630f56cd9ee8d6cf87411c18950f05f /meta/recipes-devtools/openjade/openjade-native_1.3.2.bb | |
parent | 29747d46396a7ef31104f81d03a400d52dd012b2 (diff) | |
download | poky-2ec77de50584b8c4863a1da66a2393bf64acd88e.tar.gz |
openjade-native: statically link local libs
Statically link local libs to avoid gold link issue. This is clearly
a workaround, but does get us past the failures with systems using gold by
default until we find a better solution.
[YOCTO #2972]
(From OE-Core rev: 415287be0cce596ea0d33ded0f3e6ffa9f26b775)
Signed-off-by: Christopher Larson <chris_larson@mentor.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/openjade/openjade-native_1.3.2.bb')
-rw-r--r-- | meta/recipes-devtools/openjade/openjade-native_1.3.2.bb | 22 |
1 files changed, 16 insertions, 6 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb index fa7aa62eb3..355ed6a16e 100644 --- a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb +++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb | |||
@@ -24,6 +24,10 @@ SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7 | |||
24 | 24 | ||
25 | inherit autotools-brokensep native | 25 | inherit autotools-brokensep native |
26 | 26 | ||
27 | # Statically link local libs to avoid gold link issue [YOCTO #2972] | ||
28 | PACKAGECONFIG ?= "static-only-libs" | ||
29 | PACKAGECONFIG[static-only-libs] = "--enable-static --disable-shared,--enable-static --enable-shared,," | ||
30 | |||
27 | EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \ | 31 | EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \ |
28 | --enable-splibdir=${STAGING_LIBDIR}" | 32 | --enable-splibdir=${STAGING_LIBDIR}" |
29 | 33 | ||
@@ -57,14 +61,20 @@ do_compile_prepend () { | |||
57 | do_install() { | 61 | do_install() { |
58 | # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html | 62 | # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html |
59 | # for details. | 63 | # for details. |
60 | install -d ${D}${bindir} | 64 | install -d ${D}${bindir} ${D}${libdir} |
61 | install -m 0755 ${S}/jade/.libs/openjade ${D}${bindir}/openjade | 65 | if ${@bb.utils.contains('PACKAGECONFIG', 'static-only-libs', 'true', 'false', d)}; then |
66 | install -m 0755 jade/openjade ${D}${bindir}/openjade | ||
67 | oe_libinstall -a -C style libostyle ${D}${libdir} | ||
68 | oe_libinstall -a -C spgrove libospgrove ${D}${libdir} | ||
69 | oe_libinstall -a -C grove libogrove ${D}${libdir} | ||
70 | else | ||
71 | install -m 0755 jade/.libs/openjade ${D}${bindir}/openjade | ||
72 | oe_libinstall -a -so -C style libostyle ${D}${libdir} | ||
73 | oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir} | ||
74 | oe_libinstall -a -so -C grove libogrove ${D}${libdir} | ||
75 | fi | ||
62 | ln -sf openjade ${D}${bindir}/jade | 76 | ln -sf openjade ${D}${bindir}/jade |
63 | 77 | ||
64 | oe_libinstall -a -so -C style libostyle ${D}${libdir} | ||
65 | oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir} | ||
66 | oe_libinstall -a -so -C grove libogrove ${D}${libdir} | ||
67 | |||
68 | install -d ${D}${datadir}/sgml/openjade-${PV} | 78 | install -d ${D}${datadir}/sgml/openjade-${PV} |
69 | install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV} | 79 | install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV} |
70 | install -m 644 dsssl/*.dtd ${D}${datadir}/sgml/openjade-${PV} | 80 | install -m 644 dsssl/*.dtd ${D}${datadir}/sgml/openjade-${PV} |